Opened 7 years ago

Closed 3 years ago

#2374 closed defect (invalid)

cunit failures not flagged as failures

Reported by: robe Owned by: robe
Priority: medium Milestone: Management 2.0
Component: buildbots Version: 2.0.x
Keywords: Cc:

Description

I just noticed this issue when setting up pointcloud build job that it was registering success even when cunit failures. I dont' think this has been an issue in postgis since the perl tests give standard errors that jenkins picks up.

I have a similar issue with pgrouting (I think also with how ctest from cmake outputs errors).

Seems I have to do some complicated stuff to get jenkins to correctly flag these errors.

http://stackoverflow.com/questions/10623800/cunit-failures-in-hudson-show-success

As noted in above thread. I hope there is an easier solution.

Change History (5)

comment:1 Changed 7 years ago by robe

Resolution: invalid
Status: newclosed

nevermind. Cunit is fine. it was make install causing the issue because I didn't force an exit on cunit failure.

Just cmake tests I have issue with.

comment:2 Changed 7 years ago by robe

Resolution: invalid
Status: closedreopened

on second thought cunit may not be fine.

comment:3 Changed 5 years ago by pramsey

I just confirmed that cu_tester returns non-zero on error (standard unix protocol for signalling error) so I'm not sure what you're seeing here.

comment:4 Changed 5 years ago by robe

Milestone: PostGIS 2.2.0Management 2.0

comment:5 Changed 3 years ago by strk

Resolution: invalid
Status: reopenedclosed

Closing as starved by lack of feedback.

Note: See TracTickets for help on using tickets.