Opened 9 years ago

Closed 7 years ago

#2342 closed enhancement (fixed)

join notice now giving jointype number instead of something descriptive

Reported by: robe Owned by: pramsey
Priority: medium Milestone: PostGIS 2.2.0
Component: postgis Version: master
Keywords: Cc:

Description

 SELECT restaurant_name, c.county_name
 from restaurants as r left join counties as c ON sT_Intersects(r.geom, c.geom)
 limit 10;

In notice gives:

NOTICE:  gserialized_gist_joinsel: jointype 1 not supported

This is very minor gripe since the old (1.5, I don't have 2.0 handy to check) was less informative and gave

NOTICE:  LWGEOM_gist_joinsel called with incorrect join type

But it does beg the question what is a jointype 1

Change History (6)

comment:1 by realityexists, 8 years ago

"But it does beg the question what is a jointype 1" - yes, and more generally: what is this message trying to tell me? What, if anything, should I do about it?

I get this from a query that does "LEFT JOIN ON (… OR ST_DWithin(…))" The query seems to work as intended and it's not an error or warning, but is it safe to ignore it? I have no idea.

comment:2 by robe, 8 years ago

Yes safe to ignore. It's just telling you PostGIS is too wimpy to figure out the optimal plan so the plan may not be the best possible that can be done. The issue has existed since the dawn of PostGIS and I've whined enough to lose my voice over it.

comment:3 by realityexists, 8 years ago

Thanks. In that case, while you're changing the message to a better one, could you add something like that to make its impact clearer? Eg. "gserialized_gist_joinsel: join type LEFT JOIN not supported - query plan may not be optimal" It also sounds to me like this should be a DEBUG-level message, unless some users may understand what it means and do something about it.

comment:4 by realityexists, 8 years ago

I Google that message every couple of months or so when I forget what it means, finding this ticket all over again. Could you please make this a DEBUG-level message and preferably make the meaning clearer?

comment:5 by robe, 8 years ago

Agree we should make it a DEBUG level. It alarms people for no good reason.

comment:6 by pramsey, 7 years ago

Resolution: fixed
Status: newclosed

Demoted message to debug at r13755

Note: See TracTickets for help on using tickets.