Opened 10 years ago

Closed 9 years ago

#2339 closed defect (fixed)

PostgreSQL 9.3beta1 EDB regress failures

Reported by: robe Owned by: robe
Priority: critical Milestone: PostGIS 2.1.0
Component: postgis Version: master
Keywords: windows64, edb Cc:

Description

As stated mingw-w64 works fine, but when tested against EDB 9.3beta1 w64-bit I see 3 regress failures. These are not just failures but crashers.

regress (this one fails on 9.2 EDB w64 as well presumably because of the issues we've already noted with ST_AsText and friends)

long_xact

and this last one which actually works fine on 9.2 edb 64 but fails on 9.3 beta w64 edb

sql-mm-compoundcurve

As usual raster and topology pass with flying colors.

Change History (4)

comment:1 by robe, 10 years ago

Owner: changed from pramsey to robe

comment:2 by robe, 10 years ago

regress no longer fails after r11482 but I misspoke about the number of crashers here. Actually a lot more for both 9.2 and 9.3.

Next on my list to clobber is

typmod .. failed (diff expected obtained: /tmp/pgis_reg/test_66_diff) (this is from 2.0 branch, haven't verified its a 2.1 failure but I think it is too)

comment:3 by robe, 10 years ago

hmm typmod is fine in 9.2.4 (I was testing against my old 9.2beta1 chucked that) but interestingly long_xact, and the failing curved was passing in 9.2beta1 but not 9.2.4

comment:4 by robe, 9 years ago

Keywords: windows64 edb added
Resolution: fixed
Status: newclosed

Yippie — building against mingw64-gcc 4.8.0 with seh makes regress against EDB 9.3beta1 64-bit pass all regression tests.

I'm building up a new ming64gcc48 and will use that on winnie to build the 9.3s from now on (but will keep my original ming64 until I switch the others to use the new chain since the chains are incompatible). So I'll close this one out and reopen a separate buildbot ticket.

Note: See TracTickets for help on using tickets.