Opened 11 years ago

Closed 9 years ago

#2335 closed defect (fixed)

rename internal LWGEOMWKB to be a bit more clear it is for EWKB

Reported by: robe Owned by: pramsey
Priority: medium Milestone: PostGIS 2.2.0
Component: postgis Version: master
Keywords: Cc:


I normally don't get offended by naming conventions, but this one is really offending my sense of etiquette.

As noted in #2332

We have two internal functions: LWGEOMFromWKB (which is used for ewkb conversion) -

and LWGEOM_from_WKB ( )(which is used for plain WKB conversion). From the anming its really hard to know thier is a difference. If we can't consolidate these, can we at least call LWGEOMFromWKB LWGEOMFromeWKB or something so its clearer its purpose?

Change History (2)

comment:1 by robe, 11 years ago

Milestone: PostGIS 2.1.0PostGIS 2.2.0

comment:2 by pramsey, 9 years ago

Resolution: fixed
Status: newclosed

Done, r13451

Note: See TracTickets for help on using tickets.