Opened 8 years ago

Closed 8 years ago

#2326 closed defect (fixed)

[raster]: ST_ColorMap doesn't respect nodata value

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.1.0
Component: documentation Version: master
Keywords: Cc:

Description

As far as I can tell even with a custom color map that explicitly specifies an nv, I can't get the returning raster to have a no data value, which forces me to do:

ST_SetNoDataValue(ST_SetNoDataValue(ST_SetNoDataValue(ST_ColorMap(.. so that I can overlay it on another raster without it covering up the features.

If this is by design it should be stated in docs so might just be a doc bug.

Change History (3)

comment:1 Changed 8 years ago by Bborie Park

Version: 2.0.xtrunk

Correct. This is by design. There is no NODATA value set for any of the output raster's bands. The nv paramater just maps the source band's NODATA value to something. This is why most nv entries are: 0 0 0 0.

comment:2 Changed 8 years ago by robe

Component: rasterdocumentation
Owner: changed from Bborie Park to robe

comment:3 Changed 8 years ago by robe

Resolution: fixed
Status: newclosed

documented with a warning note at r11458 and r11459

Note: See TracTickets for help on using tickets.