Opened 11 years ago

Closed 11 years ago

#228 closed defect (fixed)

postgis_restore.pl createdb parameters are used also for createlang -> crash

Reported by: havatv Owned by: pramsey
Priority: medium Milestone: PostGIS 1.5.0
Component: postgis Version: 1.4
Keywords: hard upgrade, postgis_restore.pl, parameters Cc:

Description

I have installed 1.4.0, and wanted to test a hard upgrade using postgis_restore.pl, as described in the user manual (http://postgis.refractions.net/documentation/manual-1.4/ch02.html#hard_upgrade - 2.7.2 Hard upgrade).

The user manual says that postgis_restore.pl can take parameters and pass them on to createdb. This works fine. However, these parameters are also passed on to createlang, which is not happy with the createdb specific options and therefore aborts, so postgis_restore.pl is aborted as well.

With the example used in the documentation (sh utils/postgis_restore.pl postgis.sql newdb olddb.dump -E=UNICODE), I get the following error message (Norwegian translation: "ugyldig flagg": invalid flag):

    createlang: ugyldig flagg -- E
    Try "createlang --help" for more information.

Also: It could perhaps be useful to include info on upgrade in the release notes, even if soft upgrade is recommended by default (there has not been any mention of upgrading in the release notes since 1.1.6).

Change History (3)

comment:1 Changed 11 years ago by mcayland

Is this not a duplicate of #100?

ATB,

Mark.

comment:2 in reply to:  1 Changed 11 years ago by havatv

Replying to mcayland:

Is this not a duplicate of #100?

It seems so. Sorry. I should have checked.

Only new thing is the comment on mentioning upgrade procedures in the release notes.

Håvard

comment:3 Changed 11 years ago by pramsey

Resolution: fixed
Status: newclosed

Closed out at r4746.

Note: See TracTickets for help on using tickets.