Opened 5 years ago

Closed 5 years ago

#2190 closed defect (fixed)

topology regress failures on PostgreSQL 9.3

Reported by: robe Owned by: strk
Priority: blocker Milestone: PostGIS 2.1.0
Component: topology Version: trunk
Keywords: Cc:

Description

Debbie pulls the latest PostgreSQL 9.3 snapshot on Sunday and then does a regress and then tests with that for the rest of the week. This Sunday she registered a topology regress failure:

PostgreSQL 9.3devel on x86_64-unknown-linux-gnu, compiled by gcc (Debian 4.4.5-8) 4.4.5, 64-bit
  Postgis 2.1.0SVN - r11046 - 2013-01-28 06:06:36
  GEOS: 3.4.0dev-CAPI-1.8.0 r3755
  PROJ: Rel. 4.7.1, 23 September 2009

Running tests

 regress/legacy_validate .. ok 
 regress/legacy_predicate .. ok 
 regress/legacy_invalid .. ok 
 regress/sqlmm .. ok 
 regress/legacy_query .. ok 
 regress/addnode .. ok 
 regress/addedge .. ok 
 regress/addface .. ok 
 regress/addface2.5d .. ok 
 regress/addtopogeometrycolumn .. ok 
 regress/polygonize .. ok 
 regress/st_addisoedge .. ok 
 regress/st_addisonode .. failed (diff expected obtained: /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_1_pg9.3w64/test_13_diff)
 regress/st_addedgemodface .. ok 
 regress/st_addedgenewfaces .. ok 
 regress/st_changeedgegeom .. ok 
 regress/st_createtopogeo .. ok 
 regress/st_getfacegeometry .. failed (diff expected obtained: /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_1_pg9.3w64/test_18_diff)
 regress/st_getfaceedges .. failed (diff expected obtained: /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_1_pg9.3w64/test_19_diff)
 regress/st_modedgeheal .. ok 
 regress/st_modedgesplit .. failed (diff expected obtained: /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_1_pg9.3w64/test_21_diff)
 regress/st_newedgeheal .. ok 
 regress/st_newedgessplit .. failed (diff expected obtained: /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_1_pg9.3w64/test_23_diff)
 regress/st_remedgenewface .. ok 
 regress/st_remedgemodface .. ok 
 regress/topoelement .. ok 
 regress/topoelementarray_agg .. ok 
 regress/topogeo_addlinestring .. ok 
 regress/topogeo_addpoint .. ok 
 regress/topogeo_addpolygon .. ok 
 regress/topogeometry_type .. ok 
 regress/topo2.5d .. ok 
 regress/totopogeom .. ok 
 regress/droptopology .. ok 
 regress/copytopology .. ok 
 regress/createtopogeom .. ok 
 regress/createtopology .. ok 
 regress/gml .. ok 
 regress/getnodebypoint .. ok 
 regress/getedgebypoint .. ok 
 regress/getfacebypoint .. ok 
 regress/getringedges .. ok 
 regress/gettopogeomelements .. ok 
 regress/layertrigger .. ok 
 regress/validatetopology .. ok 
 uninstall .. ok (4083)

Looks like they may have changed error handling

-- addisonode - test_13_diff

11.OBT: ERROR:  SQL/MM Spatial exception - invalid topology name
11.EXP: ERROR:  relation "wrong_name.node" does not exist at character 21

-- st_facegeometry -- test_18_diff

7.OBT: ERROR:  SQL/MM Spatial exception - invalid topology name
7.EXP: ERROR:  corrupted topology "NonExistent"

-- st_faceedges -- test_19_diff

6.OBT: ERROR:  SQL/MM Spatial exception - invalid topology name
6.EXP: ERROR:  relation "NonExistent.edge_data" does not exist at character 94

anyway I think you get the gist now.

Change History (7)

comment:1 Changed 5 years ago by robe

Summary: topology regress failures on 9.3topology regress failures on PostgreSQL 9.3

comment:2 Changed 5 years ago by robe

strk,

You think you'll have a chance to look at this in the next couple of days. If not, I'll remove regress 9.3 at the mix. Poor Bborie is already being yelled at by Debbie because of these topology regress failures.

comment:3 Changed 5 years ago by strk

Yep, looks like the backend sends another kind of EXCEPTION for cases that were previously handled in a different way. I dunno when I'll be able to look at this. I like the obtained messages more for one thing (tie :) but less for another (less detail).

Again, dunno when I'll have time to look at these errors. I don't have a 9.3 around either, do you ?

comment:4 Changed 5 years ago by robe

Yes I have a 9.3 but don't have it building PostGIS yet. I'll leave the test running then and if I have a chance to take a look at it before you do I'll try to tackle. pramsey, dustymugs et al, I guess can live with a bit of misdirected yelling from Debbie until then.

comment:5 Changed 5 years ago by robe

okay I removed the 9.3 regress from the 2.1 regular battery,but left the weekly 9.3 test.

comment:6 Changed 5 years ago by robe

okay fixed one issue at r11075. I'll try to get to the rest later today or tomorrow.

comment:7 Changed 5 years ago by robe

Resolution: fixed
Status: newclosed

I finished this off at r11076 and reenabled the 9.3 regress tests on Debbie. Most of the issue is sloppiness on checking if a topology exists. In most cases we were only checking if the topology name passed in wasn't empty.

I'll reopen if she complains.

Note: See TracTickets for help on using tickets.