Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2180 closed defect (worksforme)

Postgres crashes on insert statement

Reported by: MarkRobinson Owned by: robe
Priority: critical Milestone: PostGIS 2.0.3
Component: build/upgrade/install Version: 2.0.x
Keywords: windows64 9.1 Cc:

Description

Executing this statement will crash Postgres

INSERT INTO geometries (GEOM) VALUES ('POINT(396210 363290)');

Table Defn:

create table GEOMETRIES(ID serial) WITH OIDS; SELECT AddGeometryColumn('geometries', 'geom',26915,'GEOMETRY',2);

PG version:

"PostgreSQL 9.1.4, compiled by Visual C++ build 1500, 64-bit"

PostGIS version:

"POSTGIS="2.0.1 r9979" GEOS="3.3.5-CAPI-1.7.5" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.9.1, released 2012/05/15" LIBXML="2.7.8" LIBJSON="UNKNOWN" (core procs from "2.0.0 r9605" need upgrade) RASTER (raster procs from "2.0.0 r9605" need upgrade)"

Change History (9)

comment:1 by robe, 10 years ago

Mark,

This doesn't crash on my windows 7 PostgreSQL 64-bit 9.1.3 2.0.0, 2.0.2 (or 2.1.0SVN). Unfortunately I don't have 9.1.4 readily handy or 2.0.1. So I'll need to retest later.

Which windows version are you using?

Can you check what your PostgreSQL logs say. All I get is an error which is expected:

 Geometry SRID (0) does not match column SRID (26915)

You should be doing:

INSERT INTO geometries (GEOM) VALUES (ST_GeomFromText('POINT(396210 363290)',26915)); 

comment:2 by robe, 10 years ago

Just for reference — this is what I'm running:

POSTGIS="2.0.2 r10789" GEOS="3.3.6-CAPI-1.7.6" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.9.2, released 2012/10/08" LIBXML="2.7.8" LIBJSON="UNKNOWN" RASTER

PostgreSQL 9.1.3, compiled by Visual C++ build 1500, 64-bit

comment:3 by robe, 10 years ago

Okay just tried with;

POSTGIS="2.0.1 r9979" GEOS="3.3.5-CAPI-1.7.5" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.9.1, released 2012/05/15" LIBXML="2.7.8" LIBJSON="UNKNOWN" RASTER

PostgreSQL 9.1.3, compiled by Visual C++ build 1500, 64-bit

and still no crashing. I'll try next with 9.1.4 but not seeing any issue.

You may want to upgrade your PostGIS scripts

ALTER EXTENSION postgis UPDATE TO "2.0.1";

Because though you are running 2.0.1, looks like your scripts are 2.0.0. That I don't expect to cause this issue though.

comment:4 by MarkRobinson, 10 years ago

I upgraded to PG 9.2 and PostGIS 2.0.1 and the crashing problem went away. I would be willing to assume this was fixed by the upgrade.

comment:5 by robe, 10 years ago

Component: buildbotsbuild/upgrade/install
Keywords: windows64 9.1 added
Owner: changed from robe to strk

odd though. I wonder if its a bug in 9.1.4. That's the only piece I didn't test that you had. I'll keep this open until I confirm with 9.1.4 since if that is the case, it is probably something that needs to be reported upstream to the PostgreSQL group possibly an issue with how it handles throwing errors.

comment:6 by robe, 10 years ago

Owner: changed from strk to robe

comment:7 by robe, 10 years ago

related ticket might be #2185

I guess I really got to test 9.1.4 windows 64-bit. 9.1.4 32-bit seems to work fine. So does 9.1.3 64-bit and 9.2.* 64-bit.

comment:8 by robe, 10 years ago

Resolution: worksforme
Status: newclosed

Tested on 9.1.7 64-bit on windows and don't see this issue either. I'm going to close this out sicne I can't reproduce and seems to be only demonstrable on 9.1.4

comment:9 by Mike Taves, 10 years ago

Nope, not related to #2185 as tested with my troubled Win7 x64 PostgreSQL 9.2.2 / PostGIS 2.0.1 setup. I tried several combinations of these two bugs, but my only crashes were related to WKT parsing explained in #2185

Note: See TracTickets for help on using tickets.