Opened 8 years ago

Closed 8 years ago

#2132 closed defect (fixed)

_postgis_stats crashes backend on missing stats

Reported by: strk Owned by: pramsey
Priority: medium Milestone: PostGIS 2.1.0
Component: postgis Version: master
Keywords: Cc:

Description

pg21=# select _postgis_stats('statesp020', 'geom', '2');
The connection to the server was lost. Attempting reset: Failed.
!>                                            

This may be the cause:

pg21=# select st_estimatedextent('public', 'statesp020', 'geom');
ERROR:  stats for "statesp020.geom" do not exist

... and a good output

Change History (4)

comment:1 Changed 8 years ago by strk

NOTE: _postgis_selectivity isnt' affected, and gives another (better) error message:

pg21=# select _postgis_selectivity('statesp020', 'geom', ST_MakePoint(0, 0), '2');
ERROR:  unable to load statistics! analyze?

comment:2 Changed 8 years ago by strk

Summary: _postgis_stats crashes backend_postgis_stats crashes backend on missing stats

comment:3 Changed 8 years ago by pramsey

Fixed at r10800

comment:4 Changed 8 years ago by pramsey

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.