Opened 7 years ago

Closed 7 years ago

#2048 closed defect (fixed)

Regress failure for 9.0

Reported by: robe Owned by: pracine
Priority: blocker Milestone: PostGIS 2.1.0
Component: raster Version: master
Keywords: Cc:

Description

Output from winnie

Running tests

 check_gdal .. ok 
 check_raster_columns .. ok 

 check_raster_overviews .. ok 
 rt_io .. ok 
 rt_bytea .. ok 
 box3d .. ok 

 rt_addband .. ok 
 rt_band .. ok 
 rt_dimensions .. ok 
 rt_scale .. ok 

 rt_pixelsize .. ok 
 rt_upperleft .. ok 
 rt_rotation .. ok 

 rt_georeference .. ok 
 rt_set_properties .. ok 
 rt_isempty .. ok 
 rt_hasnoband .. ok 

 rt_metadata .. ok 
 rt_raster2worldcoord .. ok 
 rt_world2rastercoord .. ok 
 rt_above .. ok 

 rt_below .. ok 
 rt_contained .. ok 
 rt_contain .. ok 

 rt_left .. ok 
 rt_overabove .. ok 
 rt_overbelow .. ok 

 rt_overlap .. ok 
 rt_overleft .. ok 
 rt_overright .. ok 

 rt_right .. ok 
 rt_same .. ok 
 rt_band_properties .. ok 

 rt_set_band_properties .. ok 
 rt_setvalues_array .. ok 
 rt_summarystats .. ok 
 rt_count .. ok 

 rt_histogram .. ok 
 rt_quantile .. ok 
 rt_valuecount .. ok 
 rt_valuepercent .. ok 

 rt_bandmetadata .. ok 
 rt_pixelvalue .. ok 
 rt_neighborhood .. ok 
 rt_nearestvalue .. ok 

 rt_pixelofvalue .. ok 
 rt_pixelaspolygons .. ok 
 rt_pixelaspoints .. ok 

 rt_pixelascentroids .. ok 
 rt_polygon .. ok 
 rt_utility .. ok 

 rt_asgdalraster .. ok 
 rt_astiff .. ok 
 rt_asjpeg .. ok 
 rt_aspng .. ok 

 rt_reclass .. ok 

 rt_resample .. ok 

 rt_asraster .. ok 

 rt_mapalgebraexpr .. ok 
 rt_mapalgebrafct .. ok 
 rt_mapalgebraexpr_2raster .. ok 

 rt_mapalgebrafct_2raster .. ok 
 rt_mapalgebrafctngb .. ok 
 rt_mapalgebrafctngb_userfunc .. ok 

 rt_intersection .. ok 
 rt_clip .. ok 
 rt_mapalgebra .. failed (diff expected obtained: /c/jenkins/postgis/tmp/2.1.0SVN_pg9.0w64/test_67_diff)

 rt_union .. ok 

 rt_invdistweight4ma .. ok 
 rt_4ma .. ok 
 rt_intersects .. ok 

 rt_overlaps .. ok 
 rt_touches .. ok 
 rt_contains .. ok 
 rt_containsproperly .. ok 

 rt_covers .. ok 
 rt_coveredby .. ok 

 rt_within .. ok 
 rt_disjoint .. ok 
 rt_dwithin .. ok 

 rt_dfullywithin .. ok 
 rt_samealignment .. ok 
 bug_test_car5 .. ok 
 tickets .. ok 

 loader/Basic ..... ok 

 loader/BasicCopy ..... ok 

 loader/Tiled10x10 .... ok 

 loader/Tiled10x10Copy .... ok 

 uninstall .. ok (3740
)

Run tests: 89
Failed: 1

Same failure from Debbie:

See attached output from winnie

Attachments (1)

2.1.0SVN_pg9.0w64_regress_failure.zip (3.8 KB) - added by robe 7 years ago.
winnie output

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by robe

winnie output

comment:1 Changed 7 years ago by robe

Bborie,

If this proves difficult to fix, I'm proposing we drop 9.0 support for 2.1.

I know we said we would only drop 8.4, but I suspect the large majority of users will be using 9.1, 9.2, or 9.3 with 2.1. That will selfishly allow me to make extension the official model for installation for 2.1 :)

comment:2 Changed 7 years ago by Bborie Park

Give me a day or two to see what I can do to fix that "ERROR: could not implement GROUP BY". That "GROUP BY" regression test would be very useful capability...

comment:3 Changed 7 years ago by Bborie Park

*Sigh* So it looks like PostgreSQL 9.1 is the old version that permits the GROUP BY using HASH opclass. So, I've added code for 9.0 that achieves the same result using the same function but with an additional step. Changes committed in r10429.

comment:4 Changed 7 years ago by Bborie Park

As for dropping 9.0 for 2.1, I have to vote no. This is purely because I don't want to upgrade my production database server from 9.0 yet. Not until 9.3 is release. ;-)

comment:5 Changed 7 years ago by Bborie Park

Resolution: fixed
Status: newclosed

Fixed in r10429

Note: See TracTickets for help on using tickets.