Opened 14 years ago

Closed 13 years ago

#185 closed enhancement (wontfix)

Enhancement to ST_PointOnSurface to support CIRCULARSTRINGS and MULTICURVES

Reported by: robe Owned by: pramsey
Priority: low Milestone: PostGIS 1.4.1
Component: postgis Version: 1.4
Keywords: Cc:

Description

In testing, I discovered that ST_PointOnSurface works for 3D LINESTRINGS and MULTIPOINTS. I assume it works because it skips GEOS since for these cases the first point in the point that defines the geometry is guaranteed to be on the surface.

Can we not do the same thing for CIRCULARLINESTRINGS and MULTICURVES?

Change History (4)

comment:1 by robe, 14 years ago

hmm slight correction I just realized for LINESTRING and MULTILINESTRING it doesn't include the boundary so is the second point and for CIRCULARSTRING and MULTICURVE since the second is the control point that isn't guaranteed to lie on the surface. Still though doesn't seem like much effort to get that to work.

comment:2 by mcayland, 13 years ago

Does anyone have an immediate fix for this at all? Or shall we just bump to 1.4.x rather than 1.4?

ATB,

Mark.

comment:3 by robe, 13 years ago

I thought I had it bumped to 1.4.1? If I hadn't apologize for that. In fact as I discovered the MM specs don't define ST_PointOnSurface/ST_Centroid for anything but Surfaces and MULTISurfaces (polygons, multipolygons, curvedpolygons ..).

I had someone check Oracle — Oracle goes by the letter on this and does not support PointOnsurface or centroid for anything but surface type geoms.

IBM supports centroid but not point on surface for non-surfaces. SQL Server 2008 supports point on surface but not centroid for non-surfaces.

So I'm acutally not sure what the expected behavior should be anyway.

comment:4 by pramsey, 13 years ago

Resolution: wontfix
Status: newclosed

This seems worthy of closing. We don't know what the behavior is and no one has asked specifically for it.

Note: See TracTickets for help on using tickets.