Opened 12 years ago

Closed 12 years ago

#1820 closed defect (fixed)

Can't compile against 9.2 beta1

Reported by: robe Owned by: pramsey
Priority: blocker Milestone: PostGIS 2.0.1
Component: postgis Version: 2.0.x
Keywords: Cc:


Now tht beta one is officially out and binaries are alreayd out, I thought it would be good to make sure we can compile against it.

Unfortunately I seem to be running into issues. Haven't tried my mingw64 yet, but under mingw32 chain I get this error:

lwgeom_triggers.c: In function `cache_bbox':
lwgeom_triggers.c:78: error: dereferencing pointer to incomplete type

Has anyone else tried compiling against 9.2 yet?

Change History (7)

comment:1 by robe, 12 years ago

Seems other people are having same issue:

excerpt from above link

It seems that compiler is complain about "Relation" structure, can you
please try adding the following in trigtest.c i.e.

#include "utils/rel.h"

comment:2 by robe, 12 years ago

This file exists in my 8.4-92 includes so I presume it would be safe to add without a conditional if PG92?

If I add this include to the postgis/lwgeom_triggers.c it gets further and then breaks at

long_xact.c: In function `check_authorization':
long_xact.c:85: error: dereferencing pointer to incomplete type
long_xact.c:102: error: dereferencing pointer to incomplete type

which I presume has the same issue.

comment:3 by robe, 12 years ago

That gets me more further and then breaks at:

geometry_estimate.c: In function `geometry_gist_joinsel_2d':
geometry_estimate.c:321: error: `Form_pg_class' undeclared (first use in this function)
geometry_estimate.c:321: error: (Each undeclared identifier is reported only once
geometry_estimate.c:321: error: for each function it appears in.)
geometry_estimate.c:321: error: syntax error before "reltup"
geometry_estimate.c:322: error: `reltup' undeclared (first use in this function)
geometry_estimate.c:333: error: syntax error before "reltup"
make[1]: *** [geometry_estimate.o] Error 1

comment:4 by robe, 12 years ago

Okay adding


to the geometry_estimate.c file allows me to compile successfully and make check goes until I get shot down by


comment:5 by robe, 12 years ago

Hmm 9.2 is now case sensitive for language if you quote the language. So our LANGUAGE 'C' prevents postgis from loading.

I think all those references need to be changed to LANGUAGE c or LANGUAGE 'c'

Right now get error

 language "C" does not exist

comment:6 by robe, 12 years ago

fixed at r9735. I overcommitted though didn't mean to commit the include util changes (just the sql file changes). Will test my 8.4 to see if it still works and then pull out if it doesn't.

comment:7 by robe, 12 years ago

Resolution: fixed
Status: newclosed

Hudson still seems happy so I'm going to close this out. Feel free to rearrange things.

Note: See TracTickets for help on using tickets.