Opened 8 years ago

Closed 7 years ago

#1762 closed enhancement (wontfix)

Provide an unpackaged from 1.5 script

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.0.2
Component: build/upgrade/install Version: 2.0.x
Keywords: Cc:

Description

If someone is running 9.1 with 1.5, they can experience a fairly clean upgrade if their old 1.5 is repackaged as an extension.

Then the upgrade process would be before they backup 1)

CREATE EXTENSION postgis VERSION "1.5.x" FROM unpackaged; 

2) run backup 3) create a new database with:

CREATE EXTENSION postgis;

4) Execute legacy_minal.sql 5) restore your backup on new db

By packaging an unpackaged PostGIS 1.5 as an extension -- all the postgis functions, tables, views from old would be guaranteed not to come back and mess up a clean postgis 2.0 install and you can still experience a clean upgrade without perl.

Change History (3)

comment:1 Changed 8 years ago by robe

Component: postgisbuild/upgrade/install
Owner: changed from pramsey to robe

comment:2 Changed 7 years ago by robe

Milestone: PostGIS 2.0.1PostGIS 2.0.2

comment:3 Changed 7 years ago by robe

Resolution: wontfix
Status: newclosed

I don't think I'll bother with this.

Note: See TracTickets for help on using tickets.