Opened 11 years ago

Closed 5 years ago

#1725 closed defect (duplicate)

Handle Empty Geometry more correctly in 2d Index

Reported by: pramsey Owned by: pramsey
Priority: medium Milestone: PostGIS Fund Me
Component: postgis Version: 2.0.x
Keywords: Cc:

Description (last modified by pramsey)

The problems that caused a crash in the ND index (#1697) could also cause some garbage results in the case of the 2D index (empty geometries being returned by the index when they shouldn't be).

Change History (6)

comment:1 by pramsey, 11 years ago

This is not going to happen without changing the structure of the BOX2DF, an index key, which means PostGIS 3.0 since it would force dump/restore (or, really, drop index, rebuild index).

comment:2 by robe, 11 years ago

Milestone: PostGIS 2.0.1PostGIS 2.1.0

If it is just a drop index / rebuild index. That is not as big of a deal since we can provide a script for that. I think that is legal to squeeze in a minor.

Heck remember PostgreSQL in 8.3 release (or was it 9.0) had a bug like that that required a reindexing (hmm might have required a full restore in fact) and we aren't even as formal as they are and they pushed it in a micro.

comment:3 by pramsey, 10 years ago

Description: modified (diff)
Milestone: PostGIS 2.1.0PostGIS Future

And yet, not sure I want to touch this. It's a problem that has existed since Time Immemorial.

comment:4 by robe, 5 years ago

Milestone: PostGIS FuturePostGIS Fund Me

Milestone renamed

comment:5 by pramsey, 5 years ago

This is a dupe of #2487

comment:6 by pramsey, 5 years ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.