Opened 10 years ago

Closed 10 years ago

#1651 closed defect (invalid)

make check runs xsltproc, without XSLTPROCFLAGS

Reported by: gdt Owned by: strk
Priority: low Milestone: PostGIS 2.0.0
Component: build/upgrade/install Version: master
Keywords: Cc:

Description

With r9403, make check calls 'make -C doc comments-install', which runs xsltproc. This is probably a bug, but it's surely a bug that XSLTFLAGS are not passed down to the comments-install target. (I had been passing XSLTPROCFLAGS=—LOSE in order to cause xsltproc invocations to fail on other than build invocations of make.)

Alternatively, this can be viewed as a bug in README.postgis, that doesn't explain that a) a doc toolchain is necessary for make check and b) one must have built comments before running make check.

Change History (1)

comment:1 by strk, 10 years ago

Resolution: invalid
Status: newclosed

It's not a bug, "make check" performs a staged install so runs all the "install" rules, only with a special prefix to install into the stage dir.

I guess the rest of the bug description is a duplicate of #1652.

Feel free to reopen if I'm mistaken

Note: See TracTickets for help on using tickets.