Opened 9 years ago

Closed 9 years ago

#1542 closed defect (invalid)

tickets.sql tests fail

Reported by: strk Owned by: pramsey
Priority: blocker Milestone: PostGIS 2.0.0
Component: postgis Version: main
Keywords: Cc:

Description

The tests for #260, #304, #657 and #1398 all fail as of r9037

Change History (10)

comment:1 Changed 9 years ago by strk

Git bisect blames r9029 for this, done for #1538

comment:2 Changed 9 years ago by pramsey

Not For Me. What are the actual regression failures?

comment:3 Changed 9 years ago by strk

-----------------------------------------------------------------------------
--- tickets_expected    2012-02-06 13:56:37.000000000 +0100
+++ /tmp/pgis_reg_32108/test_65_out     2012-02-06 20:43:25.000000000 +0100
@@ -50,7 +50,7 @@
 #241|0
 #254|010700000000000000
 #259|
-#260|1667701
+#260|0
 #261|0
 #262|POINT(-119.5434 34.9438)|t|t|t
 #262|POINT(-119.5452 34.9442)|t|t|t
@@ -65,7 +65,17 @@
 #277|<gml:Point><gml:coordinates>1,1e+308</gml:coordinates></gml:Point>
 #299|2
 #304
-#304.a|21
+POINT(-170 -80)|32702|NaN|NaN
+POINT(-170 -70)|32702|NaN|NaN
+POINT(-170 -60)|32702|NaN|NaN
+POINT(-170 -50)|32702|NaN|NaN
+POINT(-170 -40)|32702|NaN|NaN
+POINT(-170 -30)|32702|NaN|NaN
+POINT(-170 -20)|32702|NaN|NaN
+POINT(-170 -10)|32702|NaN|NaN
+POINT(-170 0)|32702|0|0
+POINT(-170 10)|32602|NaN|NaN
+#304.a|29
 #304.b|1
 #408|IllegalArgumentException: point array must contain 0 or >1 elements
 NOTICE:  IllegalArgumentException: point array must contain 0 or >1 elements
@@ -166,9 +176,9 @@
 </#1320>
 #1344|25
 #1385|
-#657.1|-166.78
-#657.2|10.00
-#657.3|t
+ERROR:  Distance must be between 0 and 1.4822e-323
+ERROR:  Distance must be between 0 and 1.4822e-323
+ERROR:  Distance must be between 0 and 1.4822e-323
 #1305.1|POINT(10 10)
 #1305.2|t
 #1305.3|t
@@ -193,5 +203,5 @@
 #1489|MULTIPOINT EMPTY|0|MULTILINESTRING EMPTY|0|MULTIPOLYGON EMPTY|0|GEOMETRYCOLLECTION EMPTY|0
 ERROR:  AddToPROJ4SRSCache: couldn't parse proj4 string: '': (null)
 #1038|
-#1398a|POINT(-119.093153 45.632669)
-#1398b|POINT(-160.137654 77.091608)
+ERROR:  Distance must be between 0 and 1.4822e-323
+ERROR:  Distance must be between 0 and 1.4822e-323

comment:4 Changed 9 years ago by pramsey

What's your proj version?

comment:5 Changed 9 years ago by strk

POSTGIS="2.0.0alpha4SVN" GEOS="3.3.2dev-CAPI-1.7.2" PROJ="Rel. 4.7.1, 23 September 2009" GDAL="GDAL 1.9.0, released 2011/12/29" LIBXML="2.7.6" USE_STATS

comment:6 Changed 9 years ago by pramsey

Is it possible that the proj includes files you are building against are different that the proj .so file you are linking against? The errors say to me: the spheroid is being initialized with the wrong numbers, but the only mechanism I can see for that to happen would be if the interpretation of the PJ struct is incorrect somehow.

comment:7 Changed 9 years ago by pramsey

Which incidentally is a fine example of why to not use the private API, but doesn't help me in the current term get access to the proj spheroid parameters.

comment:8 Changed 9 years ago by strk

It is _very_ likely, more than possible, especially because proj4 doesn't have a "make uninstall" rule ( http://trac.osgeo.org/proj/ticket/144 ).

But still, previous postgis revision didn't suffer from this regression.

comment:9 Changed 9 years ago by pramsey

It wouldn't because it didn't look directly into the PJ structure. If you could confirm that this is the problem I can at least stop worrying about the cause of the regression and most towards thinking about a solution.

comment:10 Changed 9 years ago by strk

Resolution: invalid
Status: newclosed

annoying enough it turns out that "4.7.1 released 23 September 2009" is indeed PROJ trunk, advertising itself as such ...

Dropping the new lib and the new header fixes the regression. Can't build with _only_ proj4 trunk due to the other bug you can now be thinking about a solution for :)

Note: See TracTickets for help on using tickets.