Opened 12 years ago

Closed 9 years ago

Last modified 3 years ago

#152 closed defect (wontfix)

[raster] raster_columns out-db field should be an array

Reported by: pracine Owned by: mloskot
Priority: low Milestone: PostGIS Fund Me
Component: raster Version: master
Keywords: Cc: mloskot

Description

There should be one boolean value per band for out-db.

Change History (16)

comment:1 Changed 12 years ago by pracine

Cc: mloskot added; pierre removed
Milestone: postgis 1.4.1wktraster 0.1.6
Reporter: changed from pierre to pracine

comment:2 Changed 11 years ago by mloskot

Pierre,

Are you referring to the RASTER_COLUMNS specification or its implementation?

I'm not the author of the specification, I'm the author of its implementation (still incomplete). I'm not sure I'm the right person to fix the spec. I think it's a good idea to discuss it on the list, so Frank and others have chance to give comments.

I'm assigning myself.

comment:3 Changed 11 years ago by mloskot

Owner: mloskot deleted

comment:4 Changed 11 years ago by pracine

Summary: raster_columns out-db field should be an array[wktraster]: raster_columns out-db field should be an array

comment:5 Changed 11 years ago by mloskot

Pierre, what's status of this report? Have you had chance to update the spec?

comment:6 Changed 11 years ago by mloskot

Summary: [wktraster]: raster_columns out-db field should be an array[wktraster] raster_columns out-db field should be an array

comment:7 Changed 11 years ago by pracine

Owner: set to mloskot

I updated the final specification and the documentation.

comment:8 Changed 11 years ago by pracine

Version: trunk

comment:9 Changed 11 years ago by pracine

Owner: changed from mloskot to pracine
Status: newassigned

comment:10 Changed 11 years ago by pracine

Owner: changed from pracine to mloskot
Status: assignednew

comment:11 Changed 11 years ago by jorgearevalo

So, finally the out-db field is a boolean, not an array. Isn't it?

I think that has more sense, because I don't think a raster with one band in-db and other one out-db is a common situation... All bands in-db or all bands out-db.

Am I right?

comment:12 Changed 11 years ago by pracine

Milestone: WKTRaster 0.1.6WKTRaster Future
Priority: highlow

The problem is that out-db (actually offline in rt_api.c) is a per-band variable. So I'm trying to find in situations where we could end with a raster having one or many out-db bands and one or many in-db bands. Up to now the only case I found would be something like a ST_RasterFromBands(r1, r2, r3) function constructing a multi-band raster from raster columns originating from different tables. But we could decide that such a function always produce in-db rasters...

I would say lets leave it a boolean until we get in a situation where we can not avoid having out-db and in-db bands at the same time in a raster.

I set it to WKTRaster Future so we kepep track of it.

comment:13 Changed 10 years ago by pracine

Summary: [wktraster] raster_columns out-db field should be an array[raster] raster_columns out-db field should be an array

comment:14 Changed 9 years ago by Bborie Park

Resolution: wontfix
Status: newclosed

The field out_db field no longer exists in raster_columns. It may return once out-of-db raster support is fully part of PostGIS Raster.

comment:15 Changed 9 years ago by pracine

Milestone: PostGIS Raster FuturePostGIS Future

comment:16 Changed 3 years ago by robe

Milestone: PostGIS FuturePostGIS Fund Me

Milestone renamed

Note: See TracTickets for help on using tickets.