Opened 9 years ago

Closed 9 years ago

#1149 closed defect (invalid)

PostGIS crashes server when transforming martian data

Reported by: robe Owned by: robe
Priority: high Milestone: PostGIS 2.0.0
Component: postgis Version: 1.5.X
Keywords: windows Cc: bryanhempen@…

Description

This is described in: http://postgis.refractions.net/pipermail/postgis-users/2011-July/030413.html

when converting data from: http://spatialreference.org/ref/iau2000/49900/

To: http://spatialreference.org/ref/iau2000/49910/

I have confirmed this to be an issue on Windows (my platform is Windows 7, 64-bit running PostGIS 2.0 32-bit on 9.1 beta 3).

"POSTGIS="2.0.0SVN" GEOS="3.3.1dev-CAPI-1.7.1" PROJ="Rel. 4.6.1, 21 August 2008" LIBXML="2.7.8" USE_STATS"

and shows in logs

LOG:  server process (PID 2608) was terminated by exception 0xC0000005

The person who posted this is running 8.4 on windows XP with the below but had also tried it with PostGIS 1.5 (same proj)

"POSTGIS="2.0.0SVN" GEOS="3.3.1dev-CAPI-1.7.1" PROJ="Rel. 4.6.1, 21 August 2008" LIBXML="2.7.8" USE_STATS"

This could be just an issue with windows or the older proj we compile our windows binaries with.

Our next try will be to recompile using proj 4.7 to see if we exhibit the same error and if not just bite the bullet and switch PostGIS 2.0 to use 4.7 for windows builds. Which we were planning to do anyway after some more testing.

Change History (1)

comment:1 Changed 9 years ago by robe

Resolution: invalid
Status: newclosed

Duh I should have looked at the spatial_ref_sys isnert statement generated, the 49910 is missing a proj4text string, so of course PostGIS could never transform this. Though I suppose it still shouldn't crash and we shouldn't allow inserts into spatial_ref_sys with no proj4text. That's a separate topic though.

Note: See TracTickets for help on using tickets.