Opened 8 years ago

Closed 8 years ago

#1038 closed defect (fixed)

SVG empty geometries gives invalid memory alloc

Reported by: robe Owned by: colivier
Priority: medium Milestone: PostGIS 2.0.0
Component: postgis Version: master
Keywords: Cc:

Description

This is doing regression between our current 1.5.3 and 2.0.0. I haven't tested our older 2.0.0 yet to see if it was introduced during change to gserialize.

This fails in current 2.0.0 trunk but just returns an empty string in 1.5.

 SELECT ST_AsSVG(foo1.the_geom) As result
							FROM ((SELECT ST_GeomFromText('GEOMETRYCOLLECTION EMPTY',4326) As the_geom
			UNION ALL SELECT ST_GeomFromText('LINESTRING EMPTY',4326) As the_geom
			UNION ALL SELECT ST_GeomFromText('POINT EMPTY',4326) As the_geom ) ) As foo1 LIMIT 3;

error:

ERROR:  invalid memory alloc request size 4294967294

Change History (2)

comment:1 Changed 8 years ago by pramsey

Owner: changed from pramsey to colivier

I bet this is a dupe to #1028.

comment:2 Changed 8 years ago by pramsey

Resolution: fixed
Status: newclosed

Fixed in trunk at r8920

Note: See TracTickets for help on using tickets.