Opened 13 years ago

Closed 13 years ago

#765 closed defect (fixed)

tomcat not working on the ISO version, ok on the VM version

Reported by: camerons Owned by: live-demo@…
Priority: blocker Milestone:
Component: OSGeoLive Keywords: 5.0 rasdaman


I've tried running the rasdaman quickstart, latest version at: I'm using a modified version of osgeo-live5.0rc1 + latest rasdaman script.

Issues found ... From http://localhost:8080/earthlook/demos/time-series/value-retrieval.php :

  • Click on ts_001 and get following error:

Error in executing query:

  • I get similar errors for other links ts_002, ...

From: http://localhost:8080/earthlook/demos/climate/usecase-slicing.php Click on one of the cubes, and nothing seems to happen. There is no user feedback.

Change history (8)

comment:1 by hamish, 13 years ago

notes: seems like tomcat6 is giving us problems right now.

we needed to set JAVA_HOME better, I put it in rc.local but that gets run not sourced so it wasn't exported back to the parent process. now it's in /etc/profile.d/ and hopefully it sticks.

if needed we can hardwire it in /etc/default/tomcat6

after fixing that, and setting sun's java to be the default with update-alternatives --config java, I still get a [fail] each time when I do /etc/init.d/tomcat6 start.

after changing the shebang in that script to #!/bin/sh -x the end of the output looks like:

+ sleep 5
+ start-stop-daemon --test --start --pidfile /var/run/ --user tomcat6 --exec /usr/lib/jvm/java-6-sun/bin/java
+ [ -f /var/run/ ]
+ rm -f /var/run/
+ log_end_msg 1
+ [ -z 1 ]
+ [ 91 ]
+ [ -x /usr/bin/tput ]
+ log_use_plymouth
+ [ n = y ]
+ plymouth --ping
+ printf \r
+ /usr/bin/tput hpa 91
                                                                                           + [ 1 -eq 0 ]
+ printf [
[+ /usr/bin/tput setaf 1
+ printf fail
fail+ /usr/bin/tput op
+ echo ]
+ return 1


also I notice at the end of /var/log/tomcat6/catalina.out

Aug 23, 2011 10:55:17 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive wss.war
Aug 23, 2011 10:55:19 PM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(/var/lib/tomcat6/webapps/wss/WEB-INF/lib/servlet-api-2.4.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
Aug 24, 2011 12:00:29 AM org.apache.catalina.startup.HostConfig checkResources
INFO: Reloading context [/host-manager]

the /var/lib/tomcat6/webapps/wss/WEB-INF/lib/servlet-api-2.4.jar file does exist in the filesystem, so I'm not sure if that is a useful clue or not..

??, Hamish

comment:2 by hamish, 13 years ago

more broken tomcat comments:

looking at 5.0rc2, tomcat works on the VM and does not work on the ISO.

ie sudo /etc/init.d/tomcat6 start fails.

Alex has this theory, and I think he could be on to something:

what is different between the two?

in that we use fslint's findup program to find all duplicate files on the disc and hardlink them together. as there are known to be a few duplicate copies of tomcat around which diff't projects have self-bundled, it may be that something is getting tied together which shouldn't be.

afaict there is not a simple way to ask fslint to avoid a particular directory.

currently I'm hunting for the GNU find incantation to find all files within /usr/share/tomcat6/ and /var/share/tomcat6/ which are hardlinks.

help in the next few hours from someone/anyone with a clue about tomcat would be most appreciated.

thanks, Hamish

comment:3 by hamish, 13 years ago

Priority: majorblocker

comment:4 by hamish, 13 years ago

it turns out most of the tomcats on the ISO are non-functional.

this definitely affects 52n, and maybe deegree, geonetwork, mapfish, and rasdaman too.

It seems to be the same cause as the bug: losing its +x permissions for unknown reasons.

Solution seems to be to do

chgrp tomcat6 *.sh

as it runs as the tomcat6 user, who was part of the 'chmod o-x' denied.

after chgrp to tomcat6 the /etc/init.d/tomcat6 start succeeds.

(and hope like hell it doesn't forget the group name when the build_iso runs)

there may be other problems, but this seems like it was a contributing factor.


comment:5 by hamish, 13 years ago

Summary: rasdaman quickstart demos not workingtomcat not working on the ISO version, ok on the VM version

comment:6 by hamish, 13 years ago

most seem functional in 5.0rc5 ISO except for deegree, which is colliding with the system's tomcat.

I've added modified start/stop deegree scripts in svn ./app-conf/deegree/ which turn off the system's tomcat when you start deegree, and restarts it when you stop deegree, which seems to solve the problem there.


comment:7 by darkblueb, 13 years ago

after running Start Rasdaman and Start Geomajas

  $ sudo /etc/init.d/tomcat6 status

returns a pid

appears to be fixed in RC6

comment:8 by camerons, 13 years ago

Resolution: fixed
Status: newclosed

Tried rerunning the rasdaman steps as described in the original bug report. Confirmed that rasdaman is working ok. Verified that a number of other java webapps are also working (tested 52N apps).

Used 5.0rc6 ISO in a VM with 768 Meg RAM.

Hence, closing this issue as fixed.

Note: See TracTickets for help on using tickets.