Opened 9 years ago

Closed 9 years ago

#627 closed defect (fixed)

ossim PATH setting breaks GMT and MB-System

Reported by: hamish Owned by: live-demo@…
Priority: critical Milestone:
Component: OSGeoLive Keywords: 4.0, ossim, gmt, mb-system
Cc:

Description

due to a subtle quoting bug, the OSSIM installer is hardcoding the PATH, which removes GMT from the PATH, which makes GMT and MB-System non-functional in 4.0rc9.

this is a prime example why maintaining feature-freeze discipline during the RC cycle is so important, tests on earlier RCs (pre RC8) didn't have this error.

in ~user/.bashrc it should be:

  PATH="$PATH:/usr/local/ossim:/usr/local/ossim/bin"
  export PATH

(make that edit by hand to avoid rebuilding from main.sh)

hopefully fixed for future builds in trunk with r4700, and the release branch in r4701.

:-/ Hamish

ps- many frustrating trac errors today:

  OperationalError: FATAL:  sorry, too many clients already

Change history (3)

comment:1 Changed 9 years ago by darkblueb

gmt

confirmed in rc9 via quickstart steps

mb-system

"Firefox can't find the file at /usr/local/share/osgeolive-docs/quickstart/mb-system_quickstart." using quickstart link from file:///usr/local/share/osgeolive-docs/overview/overview.html

although using the 'next' link in quickstart does find

file:///usr/local/share/osgeolive-docs/quickstart/mb-system_quickstart.html

comment:2 Changed 9 years ago by kalxas

Priority: blockercritical

is this an issue for 4.5? should we close it?

comment:3 Changed 9 years ago by hamish

Resolution: fixed
Status: newclosed

the PATH bug was fixed with r4700 before the last release. closing bug.

not sure about the status of the mb-system overview/quickstart links on the disc, but it works for me from the adhoc nightly doc build.

Hamish

Note: See TracTickets for help on using tickets.