Opened 10 years ago

Closed 10 years ago

#449 closed defect (duplicate)

All files should be owned by root, and writable by all

Reported by: camerons Owned by: live-demo@…
Priority: major Milestone:
Component: OSGeoLive Keywords:
Cc:

Description

Stefan Hansen wrote:

Hi all!

I played in the last couple of days a bit with generating an ISO-image from the VM and ran into a few problems.

One of them is that some install-scripts change the owner of some files outside $HOME to "user". Unfortunately this doesn't go well when you boot from the LiveDVD. The original "user" is deleted, when the ISO is generated, and a new user is created during the boot process (apparently that is the way things have to be). Files that belonged to the old "user" belong on the LiveDVD to the uid=1000, but the new user has the uid=999. Therefore, the new user cannot write these files and some applications won't work (so far I had problems with Geoserver and Degree, but I haven't tested all applications). So Instead of changing the owner of a file or directory, please keep root as owner and just change the access permissions. If you do so, please only change the write-permissions of a file only if you really, really have to. AFAIK everything writable is loaded into the memory, when you boot from the DVD.

cheers, stefan

-- Stefan Hansen Software Engineer LISAsoft

Change history (1)

comment:1 Changed 10 years ago by wildintellect

Resolution: duplicate
Status: newclosed

Duplicate of ticket:448

Note: See TracTickets for help on using tickets.