Opened 6 months ago

Closed 3 weeks ago

#2399 closed defect (fixed)

MapServer doc page not found

Reported by: sanak Owned by: osgeolive@…
Priority: critical Milestone: OSGeoLive16.0
Component: OSGeoLive Keywords: mapserver
Cc: osgeolive@…

Description

When starting MapServer, Firefox's 2nd tab (http://localhost/mapserver/doc) returns 404 Not Found.

Attachments (1)

missing-mapserver-doc-folder.png (48.0 KB ) - added by sanak 6 months ago.

Download all attachments as: .zip

Change history (15)

comment:1 by sanak, 6 months ago

I confirmed that MapServer doc folder doesn't exist.

There was a PR about document version upgrade,

but I confirmed that unzipped folder name is not mapserver-7-6-docs, but mapserver-7-4-docs and the contents is older 7.4 version's one, so archiving 7.6 version's doc and uploading it will solve the issue.

comment:2 by kalxas, 6 months ago

Cc: osgeolive@… added

comment:3 by kalxas, 6 months ago

Priority: normalmajor
Type: taskdefect

comment:4 by kalxas, 6 months ago

I have prepared a fixed version of that zip file, waiting for someone with permissions to delete it from the download server so I can upload the new version

/osgeo/download/livedvd/data/mapserver/mapserver-7-6-html-docs.zip

comment:6 by darkblueb, 6 months ago

done

download:/osgeo/download/livedvd/data/mapserver$ mv mapserver-7-6-html-docs.zip xmapserver-7-6-html-docs.zip

comment:7 by sanak, 6 months ago

Thanks for update.

But, the contents still seems to be older mapserver version (7.4) one (both folder name and contents (index.html)).
http://download.osgeo.org/livedvd/data/mapserver/mapserver-7-6-html-docs.zip

I am asking @geographika (Seth G) on the previous PR's comment.
https://github.com/OSGeo/OSGeoLive/pull/350#issuecomment-1207399028

comment:8 by sanak, 6 months ago

I am not sure whether 7.6 html document can be built from the following repository's branch-7-6 branch.

comment:9 by kalxas, 6 months ago

This is fixed manually in 15.0rc1 VM

comment:10 by sanak, 6 months ago

Okay, thanks for the information about rc1 VM.

I confirmed that 7.4 docs html site is launched.

comment:11 by geographika, 6 months ago

Thanks for the fix kalxas. We'll look at fixing this and uploading docs for MapServer 8.0 in the next OSGeoLive release.

comment:12 by kalxas, 3 weeks ago

Milestone: OSGeoLive15.0OSGeoLive16.0

Ticket retargeted after milestone closed

comment:13 by kalxas, 3 weeks ago

Priority: majorcritical

Since we are now moving to MapServer 8.0 we need to update docs as well.

comment:14 by kalxas, 3 weeks ago

Resolution: fixed
Status: newclosed

Original issue is fixed. Going to open a new ticket for MapServer 8.0 docs update

Note: See TracTickets for help on using tickets.