Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#2384 closed task (fixed)

Update Leaflet demo to point to Firenze

Reported by: kalxas Owned by: osgeolive@…
Priority: critical Milestone: OSGeoLive15.0
Component: OSGeoLive Keywords:
Cc: osgeolive@…

Description


Attachments (2)

leaflet-demo-location.png (420.0 KB ) - added by sanak 2 months ago.
leaflet-demo-version.png (2.7 KB ) - added by sanak 2 months ago.

Download all attachments as: .zip

Change history (16)

comment:1 by sanak, 2 months ago

I also confirmed that current beta1 vmdk version points FOSS4G 2019 Bucharest location. :)

To change the location, quick start document side fix seems to be also necessary.
(I guess that just shifting the coordinates from Bucharest to "Firenze Fiera Congress & Exhibition Center" will be enough.)

Also, I confirmed that Leaflet version is still "1.6.0" by executing L.version on Firefox Web Developer Tools - Console tab, and I felt that upgrading the version to the latest "1.8.0" will be better.

I can try above (both code and doc) at this weekend (probably Sunday), if it's no problem.

by sanak, 2 months ago

Attachment: leaflet-demo-location.png added

by sanak, 2 months ago

Attachment: leaflet-demo-version.png added

comment:2 by kalxas, 2 months ago

in reply to:  2 comment:3 by sanak, 2 months ago

Replying to kalxas:

We should be at https://packages.ubuntu.com/jammy/libjs-leaflet 1.7.1.

Thanks, I missed that bin/install_leaflet.sh uses above package...

I will check the cause why L.version returns "1.6.0".

comment:4 by sanak, 2 months ago

I checked installed leaflet.js,

$ dpkg -L libjs-leaflt
:
$ vi /usr/share/javascript/leaflet/leaflet.js

and confirmed that the header and variable versions are "1.6.0",

/* @preserve
  * Leaflet 1.6.0, ...
:
  var version = "1.6.0";

but I also confirmed that "1.7.0" API changes are included in the same file, https://github.com/Leaflet/Leaflet/releases/tag/v1.7.1

API changes

so, "1.7.1" (or "1.7.0") seems to be installed correctly except L.version.

comment:5 by darkblueb, 2 months ago

yet beta2 shows

 /usr/share/javascript/leaflet/leaflet.js

/* @preserve
 * Leaflet 1.6.0, a JS library for interactive maps. http://leafletjs.com
 * (c) 2010-2019 Vladimir Agafonkin, (c) 2010-2011 CloudMade
 */

(function (global, factory) {
  typeof exports === 'object' && typeof module !== 'undefined' ? factory(exports) :
  typeof define === 'function' && define.amd ? define(['exports'], factory) :
  (global = typeof globalThis !== 'undefined' ? globalThis : global || self, factory(global.L = {}));
})(this, (function (exports) { 'use strict';

  var version = "1.6.0";

  /*
   * @namespace Util
   *

comment:6 by darkblueb, 2 months ago

QGIS and geonode both have internal copies of leaflet

in reply to:  5 comment:7 by sanak, 2 months ago

Replying to comment:5, comment:6:

yet beta2 shows :

Yes, but actual code seems to be "1.7.1" (or "1.7.0"), so this will not be problem.

QGIS and geonode both have internal copies of leaflet

Okay, thanks for the information.

---

I can't join today's meeting from Japan, because it's midnight (28:00 JST), but if there are no further problems, then I will try the followings at tomorrow.

To change the location, quick start document side fix seems to be also necessary.
(I guess that just shifting the coordinates from Bucharest to "Firenze Fiera Congress & Exhibition Center" will be enough.)
:
I can try above (both code and doc) at this weekend (probably Sunday), if it's no problem.

comment:8 by darkblueb, 2 months ago

a simple test $ curl http://localhost/leaflet/leaflet.js returns

... v1.6 with some patches

Last edited 2 months ago by darkblueb (previous) (diff)

comment:9 by darkblueb, 2 months ago

short meeting today -- leaflet.js is installed more than once on this disk

we would like to avoid duplication and use similar versions when possible

a fresh dot-deb package for python3-ipyleaflet is the next step

a new leaflet.js will be at the same local URL

Last edited 2 months ago by darkblueb (previous) (diff)

in reply to:  9 comment:10 by sanak, 2 months ago

Replying to darkblueb:
Okay, thanks for sharing the information!

comment:11 by sanak, 2 months ago

I fixed the location on the following PRs.

---

By the way, during checking leaflet quickstart document, the following changes seem to be necessary, but those can be done on another ticket.

comment:12 by kalxas, 2 months ago

The Leaflet quickstart needs an update, mapstache is not available anymore in the disk.

comment:13 by kalxas, 2 months ago

Resolution: fixed
Status: newclosed

Leaflet demo points at Firenze on build157

in reply to:  12 comment:14 by sanak, 2 months ago

Replying to comment:12:

The Leaflet quickstart needs an update, mapstache is not available anymore in the disk.

Okay, thanks for confirmation.
I will create a new issue for that.


Replying to comment:13:

Leaflet demo points at Firenze on build157

Okay, thanks!

Note: See TracTickets for help on using tickets.