Opened 3 months ago

Closed 3 months ago

#2369 closed defect (fixed)

GeoExt fails to launch

Reported by: kalxas Owned by: osgeolive@…
Priority: critical Milestone:
Component: OSGeoLive Keywords: GeoExt
Cc: osgeolive@…

Description

Uncaught TypeError: c is not a constructor
ExtJS 2
<anonymous> http://localhost/geoext/:101
ExtJS 7

Change history (9)

comment:1 by sanak, 3 months ago

GeoExt repository name seems to be changed since v3.4.0, https://github.com/geoext/geoext/releases/tag/v3.4.0

  • Github repository was renamed from geoext3 to geoext

so I think that the following change is necessary at least. https://github.com/OSGeo/OSGeoLive/blob/master/bin/install_geoext.sh#L125

-       "https://github.com/geoext/geoext3/archive/$GEOEXT_ARCHIVE_DIST"
+       "https://github.com/geoext/geoext/archive/$GEOEXT_ARCHIVE_DIST"

From GeoExt README.md, upgrading GeoExt version from current 3.1.0 to 3.4.0 seems to be possible without dependencies upgrade.

- GEOEXT_VERSION="3.1.0"
+ GEOEXT_VERSION="3.4.0"
Last edited 3 months ago by sanak (previous) (diff)

comment:2 by kalxas, 3 months ago

Thank you for digging into this, building a new nightly with this change to test.

comment:3 by sanak, 3 months ago

Okay, no problem and thanks for confirmation!
I will check the nightly, later.

comment:4 by kalxas, 3 months ago

Same error on build95

comment:5 by sanak, 3 months ago

Okay...
I will check the cause of the error more.

comment:6 by sanak, 3 months ago

I am still checking the cause, but the following lines should be changed also...

https://github.com/OSGeo/OSGeoLive/blob/master/bin/install_geoext.sh#L140

- cd geoext3-$GEOEXT_VERSION
+ cd geoext-$GEOEXT_VERSION

https://github.com/OSGeo/OSGeoLive/blob/master/bin/install_geoext.sh#L147

- rm -rf geoext3-$GEOEXT_VERSION
+ rm -rf geoext-$GEOEXT_VERSION

I will prepare build environment locally from https://wiki.osgeo.org/wiki/Live_GIS_Build once to make sure my suggestions by myself from next time.

comment:7 by geographika, 3 months ago

@sanak @kalxas I can have a look at this if needed. The latest GeoExt has only been tested with version 6 of ExtJS.

comment:8 by sanak, 3 months ago

@geographika Okay, thanks!

I tried to prepare build environment to check above more changes locally, but I noticed that the latest bin/build_chroot.sh seems to require GitHub remote branch...

From output /var/log/osgeolive/chroot-build.log file, the error happened at the line 140, so I guess that above (=comment:6) 2 lines changes should solve the issue.

:
Copying files to /var/www/html/geoext
./install_geoext.sh: 140: cd: can't cd to geoext3-3.4.0
mv: cannot stat 'src': No such file or directory
mv: cannot stat 'LICENSE': No such file or directory
Copying done
Last edited 3 months ago by sanak (previous) (diff)

comment:9 by kalxas, 3 months ago

Resolution: fixed
Status: newclosed

Fixed in build 96

Note: See TracTickets for help on using tickets.