Opened 10 months ago

Closed 7 months ago

Last modified 7 months ago

#2266 closed defect (fixed)

actinia demo fails

Reported by: kalxas Owned by: osgeolive@…
Priority: critical Milestone: OSGeoLive14.0
Component: OSGeoLive Keywords: actinia
Cc: osgeolive@…

Description

Change history (27)

comment:1 Changed 10 months ago by neteler

comment:2 Changed 10 months ago by kalxas

yes, thanks for the update!

comment:3 Changed 10 months ago by kalxas

Type: defecttask

comment:4 Changed 10 months ago by kalxas

packages now available in nightly ppa

comment:5 Changed 10 months ago by kalxas

Summary: actinia packages missing for Focalactinia demo fails
Type: taskdefect

Package now available, demo fails to start

comment:6 Changed 9 months ago by neteler

Thanks for packaging it! So I found it at https://launchpad.net/~osgeolive/+archive/ubuntu/nightly and tried in docker for a first error analysis:

docker pull ubuntu:20.04
docker images
docker run -it --rm f643c72bc252 /bin/bash

In docker:

apt-get install software-properties-common
add-apt-repository ppa:osgeolive/nightly
apt-get update

# install actinia
apt-get install python3-actinia-core

# install GRASS GIS (needed for ace - actinia commmand execution tool)
apt-get install grass-dev wget

Testing with latest quickstart (https://osgeo.github.io/OSGeoLive-doc/en/quickstart/actinia_quickstart.html)

# test "ace" in GRASS GIS with actinia server
mkdir -p /opt/grassdata $HOME/.grass7/addons/scripts/
grass -c epsg:4326 /opt/grassdata/longlat4326

# get ace script
wget https://raw.githubusercontent.com/mundialis/actinia_core/master/scripts/ace -O $HOME/.grass7/addons/scripts/ace
chmod a+x $HOME/.grass7/addons/scripts/ace

ace --help

Time to test the connection:

# credentials from https://actinia.mundialis.de
export ACTINIA_USER='demouser'
export ACTINIA_PASSWORD='gu3st!pa55w0rd'
export ACTINIA_URL='https://actinia.mundialis.de/latest'

# list locations on server
ace --list-locations

# list mapsets in location nc_spm_08
ace --location nc_spm_08 --list-mapsets

Up to here it works in docker.

What's missing

  • some maps are (after mundialis server upgrade) not yet visible to "demouser" which we need to fix
  • same round of tests then to be done with latest test-OSGeoLive iso/VM (from http://aiolos.survey.ntua.gr/gisvm/dev/)
Last edited 9 months ago by neteler (previous) (diff)

comment:7 in reply to:  6 ; Changed 9 months ago by neteler

Replying to neteler:

What's missing

  • some maps are (after mundialis server upgrade) not yet visible to "demouser" which we need to fix

Fixed on server.

A bug was discovered in the JSON parser in GRASS GIS.

Addressed in https://github.com/OSGeo/grass/pull/1252

comment:8 in reply to:  7 Changed 9 months ago by neteler

All updated!

Replying to neteler:

Replying to neteler: A bug was discovered in the JSON parser in GRASS GIS.

Addressed in https://github.com/OSGeo/grass/pull/1252

  • GRASS GIS PR merged and actinia server redeployed.
  • actinia quickstart updated: PR-doc:656
Last edited 9 months ago by neteler (previous) (diff)

comment:9 Changed 9 months ago by kalxas

what are the next steps? should this ticket remain open?

comment:10 Changed 9 months ago by neteler

Resolution: fixed
Status: newclosed

I think it can be closed for now - doing so.

Thanks again for re-packaging actinia, @kalxas!

comment:11 Changed 9 months ago by kalxas

Just tried to startup actinia in alpha 5 and still getting an error.

comment:12 Changed 9 months ago by neteler

Resolution: fixed
Status: closedreopened

Do you have by chance the error message?

(I shall download alpha 5 and try as well)

comment:13 Changed 9 months ago by kalxas

user@osgeolive:~$ actinia_start.sh 
[2021-01-24 11:07:39 +0000] [2412] [INFO] Starting gunicorn 20.0.4
[2021-01-24 11:07:39 +0000] [2412] [INFO] Listening at: http://0.0.0.0:8088 (2412)
[2021-01-24 11:07:39 +0000] [2412] [INFO] Using worker: sync
[2021-01-24 11:07:39 +0000] [2414] [INFO] Booting worker with pid: 2414
[2021-01-24 11:07:40 +0000] [2414] [ERROR] Exception in worker process
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/gunicorn/arbiter.py", line 583, in spawn_worker
    worker.init_process()
  File "/usr/lib/python3/dist-packages/gunicorn/workers/base.py", line 119, in init_process
    self.load_wsgi()
  File "/usr/lib/python3/dist-packages/gunicorn/workers/base.py", line 144, in load_wsgi
    self.wsgi = self.app.wsgi()
  File "/usr/lib/python3/dist-packages/gunicorn/app/base.py", line 67, in wsgi
    self.callable = self.load()
  File "/usr/lib/python3/dist-packages/gunicorn/app/wsgiapp.py", line 49, in load
    return self.load_wsgiapp()
  File "/usr/lib/python3/dist-packages/gunicorn/app/wsgiapp.py", line 39, in load_wsgiapp
    return util.import_app(self.app_uri)
  File "/usr/lib/python3/dist-packages/gunicorn/util.py", line 383, in import_app
    mod = importlib.import_module(module)
  File "/usr/lib/python3.8/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 783, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/lib/python3/dist-packages/actinia_core/main.py", line 30, in <module>
    from .endpoints import create_endpoints
  File "/usr/lib/python3/dist-packages/actinia_core/endpoints.py", line 33, in <module>
    from .resources.common.logging_interface import log
  File "/usr/lib/python3/dist-packages/actinia_core/resources/common/logging_interface.py", line 33, in <module>
    from pythonjsonlogger import jsonlogger
ModuleNotFoundError: No module named 'pythonjsonlogger'
[2021-01-24 11:07:40 +0000] [2414] [INFO] Worker exiting (pid: 2414)
[2021-01-24 11:07:40 +0000] [2412] [INFO] Shutting down: Master
[2021-01-24 11:07:40 +0000] [2412] [INFO] Reason: Worker failed to boot.

comment:14 Changed 9 months ago by neteler

There is the python_json_logger dependency missing, see

https://github.com/mundialis/actinia_core/blob/master/requirements.txt#L20

pip install python_json_logger

comment:15 Changed 9 months ago by kalxas

so we need to add a debian package for it

comment:16 Changed 9 months ago by kalxas

Resolution: fixed
Status: reopenedclosed

Debian package created and dependency list updated

comment:17 Changed 7 months ago by kalxas

Resolution: fixed
Status: closedreopened

Just tested 14.0rc1 iso:

The actinia launcher from Geospatial menu does not work. Actinia only launches from the terminal.

@neteler can you please test?

comment:18 Changed 7 months ago by neteler

I downloaded osgeolive-14.0rc1-amd64.iso but don't see any menu entry for actinia. In which category should it be?

comment:19 Changed 7 months ago by kalxas

The menu launcher is in the Web Services category "Start Actinia"

comment:21 Changed 7 months ago by neteler

Great, thanks a lot.

BTW: I have updated the quickstart: https://github.com/OSGeo/OSGeoLive-doc/pull/702

comment:22 Changed 7 months ago by kalxas

The docs are frozen now, those changes would need us to unfreeze and give time for translations.

comment:23 Changed 7 months ago by neteler

I see. The problem is that the "old" way does not work. The changes are basically the commands only (or could be reduced to that) which will not be translated anyway.

comment:24 Changed 7 months ago by kalxas

Good idea. Lets wait for some feedback from Vicky before breaking the pull request in 2 parts.

comment:25 Changed 7 months ago by kalxas

Just looking at the quickstart and it seems to not be using the local actinia installation at all. Could a part be added (in the future?) to run examples without internet connection?

comment:26 Changed 7 months ago by kalxas

Resolution: fixed
Status: reopenedclosed

comment:27 in reply to:  25 Changed 7 months ago by neteler

Replying to kalxas:

Just looking at the quickstart and it seems to not be using the local actinia installation at all.

That's correct. For this a deployment like would be needed (like illustrated in https://github.com/mundialis/actinia_core/tree/master/docker).

Could a part be added (in the future?) to run examples without internet connection?

I'd say yes.

Note: See TracTickets for help on using tickets.