Opened 3 months ago

Closed 3 months ago

#2181 closed defect (fixed)

GRASS freezes when using r.import on file without projection

Reported by: johanvdw Owned by: osgeolive@…
Priority: major Milestone: OSGeoLive13.0
Component: OSGeoLive Keywords: grass
Cc: osgeolive@…

Description (last modified by kalxas)

steps to reproduce:

on osgeolive 13

  • start grass
  • start a grass session (without changing anything)
  • from the file menu choose import raster data/simplified raster import with reprojection
  • in source input go to /home/user/data/saga/DGM_30m_Mt.St.Helens_SRTM.sdat
  • click import

Change history (4)

comment:1 Changed 3 months ago by johanvdw

should be osgeolive 13 of course, seems I can not edit the description

comment:2 Changed 3 months ago by kalxas

Description: modified (diff)

comment:3 Changed 3 months ago by kalxas

Cc: osgeolive@… added
Keywords: grass added
Milestone: OSGeoLive13.0
Priority: minormajor
Type: taskdefect

comment:4 Changed 3 months ago by neteler

Resolution: fixed
Status: newclosed

Fixed, will be part of 7.6.2, 7.8.0 and later.


From: Markus Metz
Date: Tue, Sep 3, 2019 at 11:17 AM
Subject: Re: [GRASS-dev] Fwd: Re: [OSGeoLive] #2181: GRASS freezes when using r.import on file without projection

The reason was that r.import did not change back to the original location + mapset by resetting GISRC. Fixed in master, relbr78, and relbr76, also for v.import.

Markus M

Note: See TracTickets for help on using tickets.