Opened 18 months ago

Closed 15 months ago

Last modified 14 months ago

#2074 closed defect (fixed)

blue screen xorg error: problems when starting Lubuntu 18.4. or OSGeoLive 12 alpha1 with virtual box

Reported by: astrid_emde Owned by: osgeolive@…
Priority: major Milestone: OSGeoLive12.0
Component: OSGeoLive Keywords:
Cc: osgeolive@…

Description

when you run OSGeoLive builds with virtual box (without installation) it can happen, that you get stuck in a blue screen. Then it can help to type Right Ctrl F1 & Right Ctrl F7. But in some cases this does not help and you can't start OSGeoLive

Steps to reproduce

  • Download http://aiolos.survey.ntua.gr/gisvm/12.0/
  • create a virtual machine with virtual box (Linux/Ubuntu64 bit)
  • start and choose the iso
  • choose the language
  • can see the screen Lubuntu 18.4
  • but then the blue screen shows up and nothing else happens

Attachments (5)

Screen Shot 2018-06-23 at 9.16.22 am.png (140.5 KB) - added by camerons 18 months ago.
VirtualBox? settings with Lubuntu 18.04 image
Screen Shot 2018-06-23 at 9.18.08 am.png (29.8 KB) - added by camerons 18 months ago.
Try Ubuntu page
Screen Shot 2018-06-23 at 9.19.39 am.png (31.8 KB) - added by camerons 18 months ago.
Log messages
Screen Shot 2018-06-23 at 9.22.36 am.png (46.3 KB) - added by camerons 18 months ago.
Lubuntu Logo page
Screen Shot 2018-06-23 at 9.23.31 am.png (323.2 KB) - added by camerons 18 months ago.
Final fuzzy - non-rendered Lubuntu desktop page

Download all attachments as: .zip

Change history (20)

comment:1 Changed 18 months ago by camerons

To clarify for external readers, the OSGeo-Live image we use is based upon Lubuntu 18.04, and I have been able to reproduce our problem with a raw Lubuntu 18.04 image, confirming this is an upstream issue with Lubuntu rather than an issue with OSGeo-Live (which is based on Lubuntu). Steps I've used:

  • Host hardware is Macbook Air,
  • Host operating system: macOS High Serera, version 10.13.5.
  • Virtual Machine: VirtualBox? 5.2.12
  • Client ISO image: lubuntu-18.04-desktop-amd64.iso
  • From Virtual Box, boot from ISO
  • Select "Try Ubuntu without installing"
  • See some log messages
  • See blue Ubuntu logo page
  • briefly see a black page
  • See a fuzzy blue page which appears to be the Lubuntu main page which hasn't been rendered correctly (you can move the mouse around and see corresponding movement on the page)

Attached are screen shots of this sequence.

Changed 18 months ago by camerons

VirtualBox? settings with Lubuntu 18.04 image

Changed 18 months ago by camerons

Try Ubuntu page

Changed 18 months ago by camerons

Log messages

Changed 18 months ago by camerons

Lubuntu Logo page

Changed 18 months ago by camerons

Final fuzzy - non-rendered Lubuntu desktop page

comment:2 Changed 18 months ago by camerons

I've reported this issue upstream at: https://bugs.launchpad.net/lubuntu-artwork/+bug/1778309

comment:3 Changed 16 months ago by astrid_emde

  • tested with beta1.: Error still occurs when you run Lubuntu without installation -> shortcut helps Right Ctrl F3 & Right Ctrl F7.
Last edited 16 months ago by astrid_emde (previous) (diff)

comment:4 Changed 16 months ago by kalxas

Tested with beta2 and new Lubuntu 18.04.1 iso. Both have the same issue.

comment:5 Changed 16 months ago by kalxas

Cc: osgeolive@… added
Priority: normalcritical

comment:6 Changed 16 months ago by kalxas

Just confirmed that this issue is not valid with latest Virtual Box (5.2.10) on a Linux host. Can someone please test the latest version of VirtualBox? on Windows and Mac?

comment:7 Changed 16 months ago by bakaniko

Tested osgeolive-nightly-build200-amd64-34cddf6-master.iso On windows 10 professional machine.

No issues with the iso, no blue screen, window resizing works correctly

It is a intel corei5 machine with intel hd graphics 530 video chipset. so pretty basic Forgot to check the virtualbox version, not the latest as it proposed to update. Probably 4 to 6 months old.

comment:8 Changed 16 months ago by micha

The recent beta2 started fine in Virtualbox 5.2.8 on a Windows 7 host. No issues with blue screen. The desktop resized automatically (Vbox additions already installed). Nice...

comment:9 Changed 16 months ago by kalxas

Thanks! We need someone to confirm this works on Mac in order to dismiss this ticket.

comment:10 Changed 16 months ago by kalxas

We still need a volunteer with a Mac to test latest VirtualBox? and latest beta.

comment:11 Changed 16 months ago by sethg

I had the same issue - see mailing list: https://lists.osgeo.org/pipermail/osgeolive/2018-August/013433.html

I needed to "Enable 3D Acceleration" in the settings: https://imgur.com/a/XxaudE0

This was not the case for OSGeoLive 11 so I guess this should be added to the installation notes?

PC details which may be relevant:

Operating System: Windows 10 Pro 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)           
Card name: NVIDIA GeForce GTX 1060 6GB
Manufacturer: NVIDIA
Chip type: GeForce GTX 1060 6GB
Processor: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz (8 CPUs), ~3.6GHz
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Last edited 16 months ago by sethg (previous) (diff)

comment:12 Changed 16 months ago by kalxas

We should add this setting in the Virtual Machine quickstart.

comment:14 Changed 15 months ago by kalxas

Resolution: fixed
Status: newclosed

Could not replicate the issue on 12.0 vm version

comment:15 Changed 14 months ago by bakaniko

This issue seems to be Ubuntu related, it appends in Ubuntu MATE as well:

https://ubuntu-mate.org/blog/ubuntu-mate-cosmic-beta/

"This appears to impact Ubuntu (proper) more than Ubuntu MATE. It is an intermitent problem on Ubuntu MATE and simply resetting the VM may work on the next boot. If not, press a key when the initial boot prompt (Man and Keyboard) is displayed, then press F6 and select nomodeset and press ENTER to boot."

Bug report: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1792932

Note: See TracTickets for help on using tickets.