#2067 closed defect (fixed)

Mapbender installer has to be configured for PHP7 in Bionic

Reported by: kalxas Owned by: osgeolive@…
Priority: critical Milestone: OSGeoLive12.0
Component: OSGeoLive Keywords: mapbender
Cc: osgeolive@…

Description

Currently the script uses php5.6 packages that are not available in Bionic anymore.

Change history (4)

comment:1 Changed 18 months ago by astrid_emde

Summary: MapBender installer has to be configured for PHP7 in BionicMapbender installer has to be configured for PHP7 in Bionic

Thanks for the feedback. I changed the script to PHP 7 but at the moment Mapbender does not work with PHP 7.2 and PostgreSQL 10.

I will discuss this with the Mapbender team.

comment:2 Changed 18 months ago by kalxas

Just did a grep for php in our code base and looks like MapBender? is the only project using PHP right now (Cartaro, Ushahidi have been retired).

Should we consider porting PHP5 to Bionic (as we did for Xenial)?

comment:4 Changed 17 months ago by kalxas

Resolution: fixed
Status: newclosed

Fixed in master

Note: See TracTickets for help on using tickets.