Opened 2 years ago

Closed 3 months ago

#1978 closed defect (invalid)

Mapbender3 access rights for files are not right - user is set to 1000 instead of user

Reported by: astrid_emde Owned by: astrid_emde
Priority: normal Milestone: OSGeoLive13.0
Component: OSGeoLive Keywords:
Cc: osgeolive@…

Description

access rights for mapbender3 files are not right - user is set to 1000 instead of user

Mapbender3 is located at /var/www/html/mapbender3

In the install script is a command that passes all files to user as owner and www-data as group: https://github.com/OSGeo/OSGeoLive/blob/master/bin/install_mapbender3.sh#L107

chown -R user:www-data "$INSTALL_DIR/mapbender3"

cd /var/www/html ls -l

it says: drwxr-xr-x 12 1000 www-data mapbender3

Like this it is not possible to edit the files as user user without setting chown again.

What happened on install. Was somthing wrong?

Change history (5)

comment:1 Changed 3 months ago by kalxas

Milestone: OSGeoLive11.0OSGeoLive13.0

Is this still valid?

comment:2 Changed 3 months ago by kalxas

Cc: osgeolive@… added
Type: taskdefect

comment:3 Changed 3 months ago by astrid_emde

@kalxas - I will have a look

comment:4 Changed 3 months ago by astrid_emde

Owner: changed from live-demo@… to astrid_emde

comment:5 Changed 3 months ago by astrid_emde

Resolution: invalid
Status: newclosed

Can't reproduce the error in 13.0beta2

I close the issue

Note: See TracTickets for help on using tickets.