Opened 2 years ago

Closed 2 years ago

#1933 closed defect (fixed)

GDAL error message after 2.2.0 transition

Reported by: kalxas Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive11.0
Component: OSGeoLive Keywords:
Cc: live-demo@…

Description

user@osgeolive:~$ gdalinfo --version
ERROR 1: /usr/lib/gdalplugins/2.2/gdal_GRASS.so: undefined symbol: GDALRegisterMe
ERROR 1: /usr/lib/gdalplugins/2.2/gdal_GRASS.so: undefined symbol: GDALRegister_GRASS
ERROR 1: /usr/lib/gdalplugins/2.2/ogr_GRASS.so: undefined symbol: GDALRegisterMe
ERROR 1: /usr/lib/gdalplugins/2.2/ogr_GRASS.so: undefined symbol: RegisterOGRGRASS
GDAL 2.2.0, released 2017/04/28

Change history (5)

comment:1 Changed 2 years ago by Bas Couwenberg

What are the versions of the installed grass & libgdal-grass packages?

comment:2 Changed 2 years ago by Bas Couwenberg

It's specific to the Ubuntu builds, the packages from Debian experimental don't have this issue:

# gdalinfo --version
GDAL 2.2.0, released 2017/04/28
# dpkg -l | egrep "gdal|grass"
ii  gdal-bin                                      2.2.0+dfsg-1~exp1                    amd64        Geospatial Data Abstraction Library - Utility programs
ii  gdal-data                                     2.2.0+dfsg-1~exp1                    all          Geospatial Data Abstraction Library - Data files
ii  grass                                         7.2.1-1~exp1                         all          Geographic Resources Analysis Support System (GRASS GIS)
ii  grass-core                                    7.2.1-1~exp1                         amd64        GRASS GIS core components
ii  grass-dev                                     7.2.1-1~exp1                         amd64        GRASS GIS development files
ii  grass-doc                                     7.2.1-1~exp1                         all          GRASS GIS user documentation
ii  grass-gui                                     7.2.1-1~exp1                         amd64        GRASS GIS graphical user interfaces
ii  libgdal-dev                                   2.2.0+dfsg-1~exp1                    amd64        Geospatial Data Abstraction Library - Development files
ii  libgdal-doc                                   2.2.0+dfsg-1~exp1                    all          Documentation for the Geospatial Data Abstraction Library
ii  libgdal-grass                                 2.2.0-1~exp1                         amd64        GRASS extension for the GDAL library
ii  libgdal-java                                  2.2.0+dfsg-1~exp1                    amd64        Java bindings to the Geospatial Data Abstraction Library
ii  libgdal-perl                                  2.2.0+dfsg-1~exp1                    amd64        Perl bindings to the Geospatial Data Abstraction Library
ii  libgdal20                                     2.2.0+dfsg-1~exp1                    amd64        Geospatial Data Abstraction Library
ii  python-gdal                                   2.2.0+dfsg-1~exp1                    amd64        Python bindings to the Geospatial Data Abstraction Library
ii  python3-gdal                                  2.2.0+dfsg-1~exp1                    amd64        Python 3 bindings to the Geospatial Data Abstraction Library

comment:3 Changed 2 years ago by Bas Couwenberg

Is PIE disabled for all three related packages (grass, gdal & libgdal-grass)?

It's likely that the PIE option for libgdal-grass was not disabled for the Ubuntu build causing this issue.

The buildlog confirms this:

g++ -Wall -fPIC [...] -fPIE -fstack-protector-strong -Wformat -Werror=format-security  -c -o ogrgrassdriver.o ogrgrassdriver.cpp

Add the following to debian/rules for libgdal-grass:

# Disable PIE on Ubuntu where it's still problematic
VENDOR_DERIVES_FROM_UBUNTU ?= $(shell dpkg-vendor --derives-from Ubuntu && echo yes)

ifeq ($(VENDOR_DERIVES_FROM_UBUNTU),yes)
        export DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie
endif

Or get the updated source from git:

https://anonscm.debian.org/cgit/pkg-grass/gdal-grass.git/log/?h=experimental-2.2

Last edited 2 years ago by Bas Couwenberg (previous) (diff)

comment:4 Changed 2 years ago by kalxas

Thanks Bas, the patch has been applied both to our ppa and ubuntugis-experimental

comment:5 Changed 2 years ago by kalxas

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.