Opened 8 years ago

Closed 7 years ago

#1754 closed defect (wontfix)

MapQuest error messages in Cartaro

Reported by: kalxas Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive10.0
Component: OSGeoLive Keywords: tiles
Cc: live-demo@…


As of July 11, 2016 direct tile access from MapQuest has been discontinued.

Some projects use those tiles as a base layer for their demonstrations. A quick fix would be to replace those tiles with OSM tiles.

We have always noted to projects that OSGeo-Live should be able to be used offline, so depending on external resources is not recommended.

Right now we have many alternatives for tile generation in the disk, we should try to produce a base layer and replace the external dependencies.


Attachments (2)

Screenshot_20160723_183527.png (160.3 KB ) - added by kalxas 8 years ago.
Cartaro issue
Screenshot_20160723_191244.png (171.5 KB ) - added by kalxas 8 years ago.

Download all attachments as: .zip

Change history (15)

comment:1 by kalxas, 8 years ago

Projects affected:

The list might be longer, I have not checked everything.

comment:2 by jimk, 8 years ago

GeoMoose will likely end up releasing a point release to deal with this. We also noticed that, which we also used, appears to have gone offline.

comment:3 by djay, 8 years ago

The issue with the ZOO-Project demos should now be solved by downloading a fresh copy of the examples-livedvd.tar.bz2 archive which was just updated to use OSM as we did on the official demos.

comment:4 by kalxas, 8 years ago

Thanks Gerald for the new set of examples. They will be included in the next nightly build.

comment:5 by kalxas, 8 years ago

Milestone: OSGeoLive10.0OSGeoLive10.5
Resolution: fixed
Status: newclosed

Issue fixed for GeoNode and ZOO (build 202).

GeoMoose will get an update in 10.5.

Last edited 8 years ago by kalxas (previous) (diff)

comment:6 by kalxas, 8 years ago

Resolution: fixed
Status: closedreopened

comment:7 by kalxas, 8 years ago

Milestone: OSGeoLive10.5OSGeoLive10.0

Cartaro is also affected by this issue.

comment:8 by kalxas, 8 years ago

Priority: majorcritical

by kalxas, 8 years ago

Cartaro issue

comment:9 by kalxas, 8 years ago

Viking is also affected by this issue.

by kalxas, 8 years ago

comment:11 by kalxas, 8 years ago

I have tried to fix the Cartaro issue by replacing all the MapQuest urls in the javascript files. Unfortunately, the urls are also stored in the database and my fix did not work.

Upstream maintainers confirmed the issue in a private e-mail, stating that this issue will be fixed with a new Cartaro release sometime soon. Unfortunately there is no time to fix for this release.

comment:12 by kalxas, 8 years ago

Summary: MapQuest tiles no longer availableMapQuest error messages in Cartaro

comment:13 by kalxas, 7 years ago

Resolution: wontfix
Status: reopenedclosed

Cartaro retired.

Note: See TracTickets for help on using tickets.