Opened 8 years ago

Closed 7 years ago

#1691 closed defect (fixed)

Spatialite-gui causes lubuntu 16.04 to be unresponsive

Reported by: micha Owned by: live-demo@…
Priority: major Milestone: OSGeoLive11.0
Component: OSGeoLive Keywords: spatialite-gui


The ubuntu package for spatialite-gui (2.0.0~devel2-2) causes the the desktop to totally lockup.

On a regular Ubuntu Xenial VM (running unity) it works fine.

I did a manual compile of spatialite-gui from source and got the same result.

Change history (15)

comment:1 by micha, 8 years ago

Additional info: I setup an Xubuntu Xenial VM, and installed spatialite-gui - there it runs fine. So this is definitely an LXDE problem.

comment:2 by micha, 8 years ago

And more: the same problem appears in both 32bit and 64bit Lubuntu VM's. I found that the system becomes un-responsive whenever I try to resize or move the gui window. Other actions (SQL commands, etc) work OK.

comment:3 by kalxas, 8 years ago

Hi Micha.

I cannot reproduce this in the latest nightly build. I am running a live session and not an installed VM.

comment:4 by micha, 8 years ago

Hi Angelos I started up a live session (before installing the VM), opened Spatialite-gui, and tried to resize the window, and the system froze. Same as after installation.

I reported to the Ubuntu trac system, and Bas changed the issue to wxGTK3. Apparently, the Lubuntu build of wxGTK3 is buggy. (Get's me wondering what other GTK based apps will show problems down the line...)

For following:

Last edited 8 years ago by micha (previous) (diff)

comment:5 by johanvdw, 8 years ago

You may want to check SAGA as well - it also uses wxGTK3.

comment:6 by kalxas, 8 years ago

It is weird that I cannot reproduce this. I am testing on a remote KVM server, maybe that is the reason... I will try on a local VBox VM.

comment:7 by micha, 8 years ago

Johan: No problem with Saga

Angelos: Based on what you did, I fired up an instance in VMWare Player, and the problem disappeared! So this is specific to Oracle Virtualbox. I played with the video acceleration settings but it did not help.

comment:8 by johanvdw, 8 years ago

In that case it may be worthwile to mention which exact version of VirtualBox you were using + which host os.

comment:9 by micha, 8 years ago

I tried with both 4.3.38 and 5.0.20 - both on a Windows 7 host. Same issue in either case.

comment:10 by kalxas, 8 years ago

I just tested this issue on alpha2 iso.

Host OS: openSUSE 42.1 Leap 64bit

Virtual Box version: 5.0.18

RAM assigned to VM: 2GB

I cannot reproduce this behavior of SpatiaLite-GUI. I am thinking this issue is specific to Windows hosts.

comment:11 by micha, 8 years ago

So we have a very specific set of circumstances that cause the prob: Only Lubuntu (other Ubuntu versions work fine) Only spatialite-gui (other wxGTK programs work fine) Only in a Virtualbox VM running on Windows hosts. (other VM platforms work fine, and even Virtualbox on other hosts works)

Unfortunately, that set of circumstances is probably the more popular: Windows hosts running Virtualbox.

comment:12 by kalxas, 8 years ago

Milestone: OSGeoLive10.0OSGeoLive10.5

Please check rc2 iso, which is now based on Lubuntu 16.04.1 Moving to 10.5 for now.

comment:13 by micha, 8 years ago

The problem is still there, on RC2 running in VirtualBox 5.1 (Occurs only on a Windows host)

comment:14 by kalxas, 7 years ago

Milestone: OSGeoLive10.5OSGeoLive11.0

Ticket retargeted after milestone closed

comment:15 by micha, 7 years ago

Resolution: fixed
Status: newclosed

This issue seems to be fixed now in OSGeo Live 11 beta (Tested in both VMWare and VirtualBOX on windows host)

Note: See TracTickets for help on using tickets.