Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1643 closed defect (invalid)

JOSM reports an error on start

Reported by: kalxas Owned by: live-demo@…
Priority: blocker Milestone: OSGeoLive9.5
Component: OSGeoLive Keywords: josm
Cc: live-demo@…

Description

This is reported automatically by JOSM in build190:

Debian-Release: 0.0.svn8159+dfsg1-1~trusty1
Build-Date: 2015-07-16 09:57:15
Revision: 8159
Is-Local-Build: true

Identification: JOSM/1.5 (8159 en) Linux Ubuntu 14.04.4 LTS
Memory Usage: 59 MB / 957 MB (44 MB allocated, but free)
Java version: 1.7.0_95, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u95-2.6.4-0ubuntu0.14.04.1
VM arguments: [-Djava.net.useSystemProxies=true]


Last errors/warnings:
- E: java.lang.ExceptionInInitializerError. Cause: java.lang.IllegalArgumentException: Width (0) and height (0) must be non-zero

java.lang.ExceptionInInitializerError
	at org.openstreetmap.josm.gui.layer.ImageryLayer.<init>(ImageryLayer.java:76)
	at org.openstreetmap.josm.gui.layer.WMSLayer.<init>(WMSLayer.java:170)
	at org.openstreetmap.josm.gui.layer.WMSLayer.<init>(WMSLayer.java:163)
	at org.openstreetmap.josm.io.WMSLayerImporter.<init>(WMSLayerImporter.java:36)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
	at java.lang.Class.newInstance(Class.java:383)
	at org.openstreetmap.josm.actions.ExtensionFileFilter.<clinit>(ExtensionFileFilter.java:65)
	at org.openstreetmap.josm.actions.OpenFileAction.<clinit>(OpenFileAction.java:54)
	at org.openstreetmap.josm.gui.MainMenu.<init>(MainMenu.java:150)
	at org.openstreetmap.josm.Main.<init>(Main.java:555)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:86)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:431)
Caused by: java.lang.IllegalArgumentException: Width (0) and height (0) must be non-zero
	at java.awt.image.ReplicateScaleFilter.<init>(ReplicateScaleFilter.java:102)
	at java.awt.Image.getScaledInstance(Image.java:173)
	at sun.awt.CustomCursor.<init>(CustomCursor.java:69)
	at sun.awt.X11CustomCursor.<init>(X11CustomCursor.java:43)
	at sun.awt.X11.XCustomCursor.<init>(XCustomCursor.java:42)
	at sun.awt.X11.XToolkit.createCustomCursor(XToolkit.java:1069)
	at org.openstreetmap.josm.tools.ImageProvider.getCursor(ImageProvider.java:1140)
	at org.openstreetmap.josm.actions.ImageryAdjustAction.<clinit>(ImageryAdjustAction.java:44)
	... 15 more

Change history (6)

comment:1 Changed 4 years ago by Bas Couwenberg

Try disabling assistive_technologies=org.GNOME.Accessibility.AtkWrapper in /etc/java-7-openjdk/accessibility.properties. See also: openjdk-7-jre-headless: Please re-disable atk bridge

comment:2 Changed 4 years ago by kalxas

This line was already disabled in /etc/java-7-openjdk/accessibility.properties

comment:3 Changed 4 years ago by kalxas

Tested the latest stable josm version (9979). The application starts, but the same error appears when trying to open some osm data.

comment:4 Changed 4 years ago by kalxas

It appears to be network related, josm does not work even on 9.5beta1 (josm was confirmed to work on that build a month ago)

comment:5 Changed 4 years ago by kalxas

Resolution: invalid
Status: newclosed

This seems to be a problem with the network setup of my KVM testing environment. JOSM fails to contact the OSM servers on startup and crashes.

After downloading the latest iso and testing under VirtualBox?, JOSM does not have any problem.

comment:6 Changed 4 years ago by darkblueb

built a clean test environment under VirtualBox?; cannot reproduce error.

Note: See TracTickets for help on using tickets.