Opened 5 years ago

Closed 3 years ago

#1465 closed enhancement (fixed)

add python pysal

Reported by: darkblueb Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive10.0
Component: OSGeoLive Keywords: python
Cc: live-demo@…

Description

PySAL is an open source cross-platform library of spatial analysis functions written in Python. It is intended to support the development of high level applications for spatial analysis. http://pysal.org

depends on scipy > 0.11.1 installed is 0.13.3

Change history (10)

comment:1 Changed 5 years ago by darkblueb

line #248

https://github.com/geopandas/geopandas/blob/master/geopandas/plotting.py

pysal color breaks usde if available

comment:2 Changed 5 years ago by kalxas

user@osgeolive:~$ sudo apt-get install python-pysal
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  python-pysal
0 upgraded, 1 newly installed, 0 to remove and 26 not upgraded.
Need to get 5,017 kB of archives.
After this operation, 23.0 MB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/osgeolive/release-8.5/ubuntu/ trusty/main python-pysal i386 1.9.1-0~trusty1 [5,017 kB]
Fetched 5,017 kB in 5s (985 kB/s)         
Selecting previously unselected package python-pysal.
(Reading database ... 208977 files and directories currently installed.)
Preparing to unpack .../python-pysal_1.9.1-0~trusty1_i386.deb ...
Unpacking python-pysal (1.9.1-0~trusty1) ...
Setting up python-pysal (1.9.1-0~trusty1) ...

It adds 23 MB to the disk...

comment:3 Changed 4 years ago by kalxas

Milestone: OSGeoLive8.5OSGeoLive9.0

Ticket retargeted after milestone closed

comment:4 Changed 4 years ago by kalxas

Milestone: OSGeoLive9.0OSGeoLive9.5

Ticket retargeted after milestone closed

comment:5 Changed 4 years ago by darkblueb

Live 95a_b64 --

user@osgeolive:~$ sudo apt-get install python-pysal
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  python-pysal
0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.
Need to get 5,262 kB of archives.
After this operation, 23.0 MB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/osgeolive/nightly/ubuntu/ trusty/main python-pysal amd64 1.9.1-0~trusty1 [5,262 kB]
Fetched 5,262 kB in 9s (528 kB/s)                                              
Selecting previously unselected package python-pysal.
(Reading database ... 221601 files and directories currently installed.)
Preparing to unpack .../python-pysal_1.9.1-0~trusty1_amd64.deb ...
Unpacking python-pysal (1.9.1-0~trusty1) ...
Setting up python-pysal (1.9.1-0~trusty1) ...

comment:6 Changed 4 years ago by darkblueb

live b1 testing sudo apt-get install python-tk ## fixes the issue

--------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-1-00d2cdfbd1a2> in <module>()
      2 import pysal as ps
      3 import random as rdm
----> 4 from pysal.contrib.viz import mapping as maps
      5 get_ipython().magic(u'matplotlib inline')
      6 from pylab import *

/usr/lib/python2.7/dist-packages/pysal/contrib/viz/mapping.py in <module>()
     14 import pysal as ps
     15 import numpy as np
---> 16 import  matplotlib.pyplot as plt
     17 from matplotlib import colors as clrs
     18 import matplotlib as mpl

/usr/lib/pymodules/python2.7/matplotlib/pyplot.py in <module>()
     96 
     97 from matplotlib.backends import pylab_setup
---> 98 _backend_mod, new_figure_manager, draw_if_interactive, _show = pylab_setup()
     99 
    100 

/usr/lib/pymodules/python2.7/matplotlib/backends/__init__.pyc in pylab_setup()
     26     # imports. 0 means only perform absolute imports.
     27     backend_mod = __import__(backend_name,
---> 28                              globals(),locals(),[backend_name],0)
     29 
     30     # Things we pull in from all backends

/usr/lib/pymodules/python2.7/matplotlib/backends/backend_tkagg.py in <module>()
      6 import os.path
      7 
----> 8 import Tkinter as Tk, FileDialog
      9 
     10 # Paint image to Tk photo blitter extension

/usr/lib/python2.7/lib-tk/Tkinter.py in <module>()
     40     import _tkinter
     41 except ImportError, msg:
---> 42     raise ImportError, str(msg) + ', please install the python-tk package'
     43 tkinter = _tkinter # b/w compat for export
     44 TclError = _tkinter.TclError

ImportError: No module named _tkinter, please install the python-tk package

comment:7 Changed 3 years ago by kalxas

Milestone: OSGeoLive9.5OSGeoLive10.0

Ticket retargeted after milestone closed

comment:8 Changed 3 years ago by kalxas

Is this still an issue with 10.0 alphas?

comment:9 Changed 3 years ago by kalxas

Cc: live-demo@… added

comment:10 Changed 3 years ago by kalxas

Resolution: fixed
Status: newclosed

pysal is included in our ppa

Note: See TracTickets for help on using tickets.