Opened 9 years ago

Closed 7 years ago

#1431 closed defect (fixed)

ZOO demo appears broken

Reported by: kalxas Owned by: live-demo@…
Priority: major Milestone: OSGeoLive10.5
Component: OSGeoLive Keywords:
Cc: live-demo@…


spatialtools.html demo page is not working properly on nightly 12064

Change history (10)

comment:1 by kalxas, 9 years ago

I am guessing that zoo package needs rebuild after GDAL 1.11.1 upgrade

comment:2 by kalxas, 9 years ago

After looking a bit deeper, in http://localhost/zoo-demo/spatialtools.html:

<script src="/openlayers/OpenLayers.js"></script>

After upgrading to OpenLayers3, ZOO demo broke, because it is looking for OpenLayers2... We need to keep OpenLayers2 around in the disk for demos that still use it.

comment:3 by kalxas, 9 years ago

OpenLayers2 have been brought in the build again (only the core js files, not the examples, documentation) [12076]

comment:4 by kalxas, 9 years ago

Resolution: fixed
Status: newclosed

confirmed fixed in build [12080]

comment:5 by kalxas, 7 years ago

Milestone: OSGeoLive8.5OSGeoLive10.5
Priority: criticalmajor
Resolution: fixed
Status: closedreopened

The OGR demo page seems broken due to a Javascript error. CGAL and OTB demos work fine

comment:6 by kalxas, 7 years ago

Here is the only thing logged in Firefox console:

Object { a: "EPSG:4326", b: undefined, f: null, g: null, d: "enu", c: false, e: false, p: k.mj(), i: null }  spatialtools-py-app.js:398:2

comment:7 by djay, 7 years ago

I guess that the issue should be fixed, the Geoserver in place for the demo was down. It has been restarted and I suppose this will solve the issue.

comment:8 by kalxas, 7 years ago

The demo should depend on the GeoServer included in OSGeo-Live, not an external one.

comment:9 by djay, 7 years ago

In case it has solved the issue, then we can update the JS to use the local GeoServer.

Can you please confirm that it has solved the issue first ?

comment:10 by kalxas, 7 years ago

Resolution: fixed
Status: reopenedclosed

yes, thank you Gerald, the issue is fixed now.

Note: See TracTickets for help on using tickets.