Opened 5 years ago

Closed 5 years ago

#1392 closed defect (wontfix)

Cannot upload new data in GeoNode

Reported by: kalxas Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive8.0
Component: OSGeoLive Keywords: GeoNode
Cc: live-demo@…

Description

The UI is complaining about incomplete file even though a full set of files for the natural earth shapefile are present.

Attachments (3)

geonode-failed-upload1.png (108.9 KB) - added by ingenieroariel 5 years ago.
GeoNode? failed upload screenshot
geonode-correct-upload1.png (85.8 KB) - added by ingenieroariel 5 years ago.
GeoNode? correct upload 1
geonode-correct-upload2.png (79.1 KB) - added by ingenieroariel 5 years ago.
GeoNode? correct upload 2

Download all attachments as: .zip

Change history (8)

comment:1 Changed 5 years ago by hamish

copied from #1379,

Still can't load data in 8.0RC1. You can select shapefile layers (I tried Natural Earth) and it adds them to the "add layers" list and parses the .prj file etc, but when you click the red button at the bottom of the page it says files are missing and can not upload, but doesn't tell you which files it can't find.

I'd also note that the screenshots and quickstart text needs to be adjusted to be relevant to the pre-seeded login name and data files available on the disc.

thanks, Hamish

comment:2 Changed 5 years ago by hamish

Hi,

I fixed a few problem in r11943

  • the patch to set the ServerName and Alias in apache 000-default.conf was not being applied.
  • the zenity sleep was too short while geoserver was starting up

In the build log, this step fails:

 django-admin updatelayers --settings=geonode.settings --ignore-errors

with a Traceback ending in:

socket.error: [Errno 111] Connection refused

but even before that:

Starting GeoServer to update layers in the geonode db
java.net.ConnectException: Connection refused

so probably geoserver isn't even running.

Hamish

Changed 5 years ago by ingenieroariel

Attachment: geonode-failed-upload1.png added

GeoNode? failed upload screenshot

Changed 5 years ago by ingenieroariel

Attachment: geonode-correct-upload1.png added

GeoNode? correct upload 1

Changed 5 years ago by ingenieroariel

Attachment: geonode-correct-upload2.png added

GeoNode? correct upload 2

comment:3 Changed 5 years ago by ingenieroariel

Hamish, thanks for the report. I tested RC2 and was able to upload files.

  1. The instructions should tell people to start GeoNode? from the menu if they do not say it already. This takes care of starting Geoserver. Could this be what happened to you in this ticket and #1379
  1. When GeoNode? finds companion files that are unused it reports them too loudly (for example html or qgs files, see attachment "geonode failed upload". I filed this in GeoNode?'s tracker: https://github.com/GeoNode/geonode/issues/1665
  1. I selected all the files in the natural earth folder and ended up with 13 loaded layers.
  1. The thumbnails are missing after the layers are uploaded, I am working on that one now and will file it as another bug.

Can we close this one as invalid or worksforme ?

comment:4 Changed 5 years ago by kalxas

File upload works for me too in RC2

The problem is that during build, django-admin did not manage to upload layers in GeoNode?.

comment:5 Changed 5 years ago by darkblueb

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.