Opened 5 years ago

Closed 3 years ago

#1385 closed defect (wontfix)

Start Geomajas: error 503

Reported by: rouault Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive10.0
Component: OSGeoLive Keywords: geomajas
Cc: live-demo@…

Description

Start Geomajas: a browser opens with a HTTP ERROR : 503. Problem accessing /showcase. Service Unavailable

Change history (9)

comment:1 Changed 5 years ago by kalxas

Cc: live-demo@… added
Milestone: OSGeoLive8.0
Type: taskdefect

comment:2 Changed 5 years ago by hamish

Keywords: 8.0 removed

it starts up ok for me in nightly iso build r11826. (I gave the VM 1800mb RAM, 5 CPUs)

was the CPU meter in the bottom taskbar back to 0% before the browser started? how much ram?

thanks, Hamish

comment:3 Changed 5 years ago by rouault

On a fresh start on a VM with 1GB RAM, it works. But if I tried launching other things before, it doesn't. Not sure about the CPU load when I had the problem.

comment:4 Changed 5 years ago by kalxas

Milestone: OSGeoLive8.0OSGeoLive8.5

I checked again and was able to reproduce after testing lots of Java apps. It seems to be an out of memory issue. Geomajas works fine when launched first.

Thanks for the report.

comment:5 Changed 5 years ago by kalxas

Milestone: OSGeoLive8.5OSGeoLive9.0

comment:6 Changed 4 years ago by darkblueb

tested in Live9 64bit build 125; launching from the command line shows an example in the Firefox browser

http://localhost:3420/showcase/

but, there is a heavy CPU load when opening it.. on a relatively fast machine with RAM allocated, it is SLOW to open

comment:7 Changed 4 years ago by kalxas

Milestone: OSGeoLive9.0OSGeoLive9.5

Ticket retargeted after milestone closed

comment:8 Changed 3 years ago by kalxas

Milestone: OSGeoLive9.5OSGeoLive10.0

Ticket retargeted after milestone closed

comment:9 Changed 3 years ago by kalxas

Resolution: wontfix
Status: newclosed

This issue has to do with resources available to the system. On a VM with low memory, Java runs out of memory soon. Nothing to do.

Note: See TracTickets for help on using tickets.