Opened 6 years ago

Closed 6 years ago

#1318 closed defect (fixed)

Issues with OSGeo-Live sourceforge downloads for 7.9 release

Reported by: camerons Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive7.9
Component: OSGeoLive Keywords: 7.9, sourceforge
Cc:

Description

On 03/13/2014 02:02 PM, Alex Mandel wrote:

FYI it looks like the download links aren't 100% correct. The redirect on Downloads doesn't appear to be working right and send you to the files section but not the correct file. I'm looking into it.

Thanks, Alex

It's not a bug on our end, something is wrong with Sourceforge. Clicking any download link in http://sourceforge.net/projects/osgeo-live/files/7.9/ sends me back to http://sourceforge.net/projects/osgeo-live/files

Older versions seem to be working. Can anyone else confirm?

Thanks, Alex

Change history (8)

comment:1 Changed 6 years ago by hamish

Keywords: sourceforge added

the error on the SF page I get is a red popup window in the top right:

The "/7.9/osgeo-live-7.9...9/osgeo-live-7.9.iso" file could not be found or is not available. Please select another file.

and then it kicks you back to the main files/ version listing.

Hamish

comment:3 Changed 6 years ago by Bas Couwenberg

You can replace the mirror argument in the URLs to need bash the skylink mirror too much.

A list of mirror short names can be found on the SF wiki:

http://sourceforge.net/apps/trac/sourceforge/wiki/Mirrors

comment:4 Changed 6 years ago by hamish

#sourceforge on Freenode:

Sourceforge.net business hours are approximately 12:00 to 21:00 UTC, excluding
weekends and holidays. Currently, it is Fri Mar 14 23:00:27 2014 UTC.

<zeromuisa> this seems to happen with some regularity for large files, usually
immediately after business hours on friday

comment:5 Changed 6 years ago by hamish

The above direct-to-mirror links don't work for me; same trouble. :-/

fwiw, if we can get it to work I'd suggest to use "&use_mirror=colocrossing".

Note Alex would have to modify the redirect URL on download.osgeo, since the apache sites-avail conf files aren't group owned.

Hopefully Sourceforge sorts itself out in 6-12 hours and we don't have to do anything.

regards, Hamish

comment:6 Changed 6 years ago by hamish

strangely, the above direct links work for me via wget but not the browser. more experimentation needed...

reported to SF in this ticket:

https://sourceforge.net/p/forge/site-support/7087/

Hamish

comment:7 Changed 6 years ago by hamish

Hi,

The sourceforge downloads seem to be working now.

Hamish

comment:8 Changed 6 years ago by hamish

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.