Opened 6 years ago

Closed 5 years ago

#1314 closed defect (wontfix)

apt-get install openssh-server fails

Reported by: darkblueb Owned by: live-demo@…
Priority: major Milestone: OSGeoLive7.9
Component: OSGeoLive Keywords:
Cc:

Description

build 11246 and b11289

install ends with

initctl: Unknown job: ssh
start: Unknown job: ssh

Change history (9)

comment:1 Changed 6 years ago by darkblueb

Component: Systems AdminLiveDVD
Milestone: OSGeoLive7.9
Owner: changed from sac@… to live-demo@…
Priority: normalcritical
Type: taskdefect

comment:2 Changed 6 years ago by darkblueb

as HamishB points out, simply executing this prior to the install appears to fix it

sudo chmod g-w /usr

comment:3 Changed 6 years ago by darkblueb

fix committed in r11313 -- needs retest to close

comment:4 Changed 6 years ago by kalxas

still not working in [11315]

comment:6 Changed 6 years ago by kalxas

Priority: criticalmajor

comment:7 Changed 6 years ago by kalxas

openssh-server works on installed VM

comment:8 Changed 6 years ago by hamish

on a booted-usb of build 11315 I still have to do this (as hinted in the launchpad bug report) to get the ssh server started:

# initctl reload-configuration
# service ssh restart

noted in the wiki:

http://wiki.osgeo.org/wiki/Live_GIS_Disc_FAQ#Administration

Hamish

comment:9 Changed 5 years ago by hamish

Resolution: wontfix
Status: newclosed

caused by a bug in 12.04,

https://bugs.launchpad.net/ubuntu/+source/linux-meta/+bug/1015348

noted in the FAQ,

http://wiki.osgeo.org/wiki/Live_GIS_Disc_FAQ#Administration

closing ticket. (please reopen if it still happens with 14.04)

Hamish

Note: See TracTickets for help on using tickets.