Opened 6 years ago

Closed 5 years ago

#1290 closed defect (fixed)

Zoo Project needs packaging

Reported by: kalxas Owned by: kalxas
Priority: major Milestone: OSGeoLive8.0
Component: OSGeoLive Keywords:
Cc: live-demo@…

Description

The old tarball is not built against new mapserver, gdal etc. We either need a new tarball or better a deb package for it :)

When the demo page is loaded, the map shows fine but the processing tools do not work as expected.

Change history (20)

comment:1 Changed 6 years ago by kalxas

testing fix in [11125]

comment:2 Changed 6 years ago by kalxas

second fix in [11138] The file seemed to be a gzip one... converted back to tar -j

comment:3 Changed 6 years ago by kalxas

The new version is installed in [11138] but the processing tools do not work.

comment:4 Changed 6 years ago by kalxas

The ZOO-Kernel seems to be working, the GetCapabilities? request is responding, wondering if the problem is with the demo page.

comment:5 Changed 6 years ago by kalxas

I created a deb file for zoo [11161], first test shows the problem is fixed now. Will confirm in next nightly.

comment:6 Changed 6 years ago by kalxas

Priority: criticalmajor

Steps to fix on beta3:

# wget http://download.osgeo.org/livedvd/data/zoo/zoo-project_1.3.0-2_i386.deb
# sudo dpkg -i zoo-project_1.3.0-2_i386.deb

comment:7 Changed 6 years ago by kalxas

Milestone: OSGeoLive7.9OSGeoLive8.0
Priority: majornormal
Summary: Zoo Project needs rebuilding/packagingZoo Project needs packaging
Type: defectenhancement

Fixed in build [11163] I am leaving the ticket open for us to remember that ZOO needs to be packaged for UbuntuGIS

comment:8 Changed 5 years ago by kalxas

Priority: normalmajor
Type: enhancementdefect

I have completed deb packaging for ZOO. Missing demo files as part of the deb (since demo is not included in the official tarball) https://launchpad.net/~gcpp-kalxas/+archive/osgeolive/+sourcepub/4228809/+listing-archive-extra

comment:9 Changed 5 years ago by darkblueb

on a2 with Apache 2.4, I see (?)

user@live8-a2:~/gisvm/bin$ ls -l /var/www
total 16
drwxr-xr-x 26 root root 4096 Jun 16 10:33 html/
drwxr-xr-x  2 root root 4096 Feb  4  2011 temp/
drwxr-xr-x  2 root root 4096 Jun 16 09:41 zoo/
drwxr-xr-x  3 root root 4096 Jun 16 09:41 zoo-demo/

comment:10 Changed 5 years ago by kalxas

Yes, the demo is not yet ported to new apache

comment:11 Changed 5 years ago by kalxas

Owner: changed from live-demo@… to kalxas
Priority: majorcritical

comment:12 Changed 5 years ago by kalxas

Debian packaging completed for ZOO. Fix committed in [11603]

comment:13 Changed 5 years ago by kalxas

Priority: criticalmajor

comment:14 Changed 5 years ago by kalxas

After completing the packaging in [11603], the WPS ZOO kernel is working, but the demo page has problems.

comment:15 Changed 5 years ago by kalxas

Fixed in [11611]

comment:16 Changed 5 years ago by hamish

Is the debian/ packaging rules stored in svn/git somewhere? or just from

https://launchpad.net/~gcpp-kalxas/+archive/ubuntu/osgeolive/+sourcepub/4228809/+listing-archive-extra

?

(we could make you an account on DebianGIS's git for it if you like for wider exposure+collaboration)

thanks, Hamish

comment:17 Changed 5 years ago by kalxas

I have committed the rules in zoo svn a few hours ago. Yes, a Debian git account for zoo would be great too.

comment:18 Changed 5 years ago by Bas Couwenberg

@kalxas, you're already a member of the Debian GIS team, and therefor have commit access to the group git repositories on Alioth.

I welcome a zoo package for Debian upstream. Just as for your other recent packaging work.

Most of what you need to know is documented in the Debian GIS Policy

comment:19 Changed 5 years ago by kalxas

Thanks, I did not know I had access to create new git repos in Alioth, I just knew I had member access :)

comment:20 Changed 5 years ago by kalxas

Resolution: fixed
Status: newclosed

confirmed working in [11633]

Note: See TracTickets for help on using tickets.