Opened 7 years ago

Closed 5 years ago

#1107 closed defect (fixed)

gvSIG throws a java error when trying to zoom in

Reported by: kalxas Owned by: jsanz
Priority: minor Milestone: OSGeoLive8.0
Component: OSGeoLive Keywords: gvsig
Cc: live-demo@…

Description

This crash happens only on the demo map, on the print preview window. When users moves to data Views, no such issue occurs.

Attachments (1)

gvsig_osgeolive_bug1107.jpg (89.0 KB) - added by hamish 7 years ago.
gv sig illegal width, height error message

Download all attachments as: .zip

Change history (18)

comment:1 Changed 7 years ago by hamish

Hi,

I can reproduce, just open up gvSIG and zoom in on Ben Nevis.

"Width and height can not be <= 0"

screenshot attached. (argh I always forget to turn of the compositor before taking screenshots and they end up huge..)

Hamish

Changed 7 years ago by hamish

Attachment: gvsig_osgeolive_bug1107.jpg added

gv sig illegal width, height error message

comment:2 Changed 7 years ago by kalxas

This will not be fixed for 6.5 final (too late).

comment:3 Changed 7 years ago by hamish

Zooming in a View seems to be ok, so for testing the quickstart perhaps start down at the "How to create a map" section.

Hamish

comment:4 Changed 7 years ago by kalxas

Milestone: OSGeoLive6.5OSGeoLive7.0

comment:5 Changed 7 years ago by jsanz

Bug reported upstream at gvSIG issue tracker

https://devel.gvsig.org/redmine/issues/1633

comment:6 Changed 6 years ago by kalxas

I guess we should expect a fix with gvSIG 2.0

comment:7 Changed 6 years ago by jsanz

The bug is still present at gvSIG 2.0.

I'm afraid it's related with java7. gvSIG has not been adapted or tested with that version and maybe this is one of the issues.

Anyway, I've updated the ticket at gvSIG redmine so 2.0 devs will take a look.

comment:8 Changed 6 years ago by kalxas

It seems in build 10180 that during gvSIG 2.0 startup, there is no default project loaded, which makes this bug less obvious to the user.

comment:9 Changed 6 years ago by jsanz

We will try to add the default project during next days, but at this moment gvSIG starts fresh.

It's annoying because the bug doesn't appear at my computer using the same JVM and in fact there was one time were it didn't happened. Hard to catch the trigger, really :-S.

comment:10 Changed 6 years ago by kalxas

I don't see starting fresh as a problem. There is always the quickstart in order for the user to learn how to use the software.

comment:11 Changed 6 years ago by kalxas

Any progress on this issue?

comment:12 Changed 6 years ago by kalxas

Milestone: OSGeoLive7.0OSGeoLive7.5

comment:13 Changed 6 years ago by jldominguez

I cannot reproduce this issue in OSGeo Live DVD 7.0. Zooming in the view and in the print preview work as expected.

comment:14 Changed 6 years ago by kalxas

gvSIG is now updated to version 2.1. We need someone to test and verify that the bug is gone

comment:15 Changed 6 years ago by jsanz

It's still there, a gvSIG dev is diving into this bug on this gvSIG ticket

https://devel.gvsig.org/redmine/issues/2302

At this moment is harder to come across this bug but it can appear. Seems to be something related with using OpenJDK or even more OSGeo Live specific, as we don't have any notice of this bug elsewhere.

comment:16 Changed 6 years ago by jsanz

Milestone: OSGeoLive7.9OSGeoLive8.0
Owner: changed from live-demo@… to jsanz
Priority: normalminor
Status: newassigned

Moving this to OSGeo Live 8, since our team can't deal with this bug at this moment, lowering also the priority as the bug is quite OSGeo Live specific and not easy to reproduce.

comment:17 Changed 5 years ago by kalxas

Resolution: fixed
Status: assignedclosed

I was not able to reproduce this issue in 8.0 series. Closing the ticket.

Note: See TracTickets for help on using tickets.