Opened 7 years ago

Closed 7 years ago

#1035 closed defect (fixed)

osm2pgsql data loading fails at build time

Reported by: kalxas Owned by: hamish
Priority: major Milestone: OSGeoLive6.5
Component: OSGeoLive Keywords: 6.5
Cc: live-demo@…

Description

NOTICE: table "planet_osm_point" does not exist, skipping NOTICE: table "planet_osm_point_tmp" does not exist, skipping PREPARE get_way (int4) AS SELECT AsText?(way) FROM planet_osm_point WHERE osm_id = $1;

failed: ERROR: function astext(geometry) does not exist

LINE 1: PREPARE get_way (int4) AS SELECT AsText?(way) FROM planet_osm...

Change history (16)

comment:1 Changed 7 years ago by darkblueb

please note that this is specific to

osm2pgsql

comment:2 Changed 7 years ago by kalxas

yes we need to rename the script because it gives the impression that PostGIS fails

comment:3 Changed 7 years ago by kalxas

Keywords: alpha 4 removed
Summary: data loading in PostGIS 2.0 fails at build timeosm2pgsql data loading fails at build time

comment:4 Changed 7 years ago by darkblueb

Owner: changed from live-demo@… to darkblueb

osm2pgsql v0.70 apparently is not compatible with PostGIS 2.0 - astext(geom) fails.. but this might be only one of many errors..

I am building osm2pgsql from svn now to test... version appears to be 0.81.

These are the packages I had to add to build osm2pgsql from source

autoconf libtool automake libxml2-dev libzip-dev libbz2-dev libgeos-dev libgeos++-dev postgresql-server-dev-9.1

comment:5 Changed 7 years ago by darkblueb

confirm that osm2pgsql 0.81 loads the .osm file correctly

comment:6 Changed 7 years ago by kalxas

perhaps there is a 0.8 stable release? (since svn seems to be at 0.81)

I found this package which is at 0.81. Perhaps we should change to this one. https://launchpad.net/~kakrueger/+archive/openstreetmap

There is a 0.80 update in the official ppa but not for 12.04 https://launchpad.net/ubuntu/+source/osm2pgsql

comment:7 Changed 7 years ago by kalxas

Attempting a fix in [9508]

comment:8 Changed 7 years ago by darkblueb

as a side note, the tool imposm is the next generation of OSM import, is stable and is used with TileMill?, for example. I see that there is already an imposm package. Loading it requires an additional 600k for me.

I am adding imposm to the installer, since it is required as we go forward with OpenStreetMap?.

comment:9 Changed 7 years ago by kalxas

Resolution: fixed
Status: newclosed

Confirmed to work on build[9511]

comment:10 Changed 7 years ago by hamish

Cc: live-demo@… added
Priority: criticalmajor
Resolution: fixed
Status: closedreopened

please move the ML email addr from the owner field if you take ownership of a ticket so it doesn't get lost


the version of osm2pgsql on the disc was custom built by me and stashed at http://download.osgeo.org/livedvd/data/osm/

see http://download.osgeo.org/livedvd/data/osm/osm2pgsql.README

If a new version is available great, let's use it, but we need to confirm that everything is up to date. this may or may not be responsible for gpsdrive's mapnik now failing.

not a blocker unless proven to be broken.

Hamish

comment:11 Changed 7 years ago by hamish

Owner: changed from darkblueb to hamish
Status: reopenednew

comment:12 Changed 7 years ago by hamish

upstream comments & solution:

https://trac.openstreetmap.org/ticket/3995

comment:13 Changed 7 years ago by darkblueb

ah - good to see the actual osm2pgsql issue in the openstreetmap tracker.. this time it was perhaps uncharacteristically easy, as most users of PostGIS will have a couple of these pre ST_prefix calls sitting around in their, not just one.. but this issue resolution does show how straightforward it can be to port forward in PostGIS... as a matter of fact, those ST_ prefixes were introduced well before 2.0, in later 1.x versions.. people have been lagging in getting rid of those non-standard original calls for literally years! Its not that hard to do!

comment:14 Changed 7 years ago by darkblueb

osm2pgsql is at version 0.81 on build 9640, so thats a GO as far as PostGIS 2.0

as noted in other tickets, there are two versions of libmapnik loaded, which is its own problem...

comment:15 Changed 7 years ago by hamish

data seems fine. closing bug.

comment:16 Changed 7 years ago by hamish

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.