Opened 13 years ago

Closed 9 years ago

#89 closed defect (fixed)

PDFLib-lite terms incompatible with OSGeo4W use of non-opensource libraries like MrSID SDK

Reported by: warmerdam Owned by: assefa
Priority: major Component: Package
Version: Keywords: pkg-pdflib
Cc:

Description

The PDFlib-lite license:

http://www.pdflib.com/fileadmin/pdflib/pdf/license/PDFlib-Lite-license.pdf

does not appear to permit use of PDFlib-lite in combination with non-open source libraries like the MrSID SDK. I do not believe OSGeo4W is behaving responsibly in incorporating PDFLib-lite.

Change History (3)

comment:1 by assefa, 13 years ago

Owner: changed from osgeo4w-dev@… to assefa
Status: newassigned

Are there any other packages using this beside MapServer. If not I could rebuild Mapserver without PDF support and get rid of the library. In any case, starting from mapserver 6.0, we will use Cairo as the main library for PDF and will eventually completly drop the PDF lib.

comment:2 by warmerdam, 13 years ago

Assefa,

I believe only MapServer uses this package. If there isn't strong demand for it, I think the thing would be to remove it's use in mapserver.

comment:3 by jef, 9 years ago

Resolution: fixed
Status: assignedclosed

removed.

Note: See TracTickets for help on using tickets.