#672 closed defect (fixed)

Testing osgeo4w installer - missing pyproj

Reported by: Calvin Owned by: osgeo4w-dev@…
Priority: major Component: Installer
Version: Keywords:
Cc:

Description

I was testing the QGIS install with http://download.osgeo.org/osgeo4w/testing/osgeo4w-setup.exe and found that one of my plugins failed because "import pyproj" is missing.

Change History (5)

comment:1 Changed 10 months ago by jef

not reproducable. is python3-pyproj installed?

comment:2 Changed 10 months ago by Calvin

I have tried it on two different computers. The one running the Express Desktop Install and the other Advanced Install. In the advanced install it shows python3-pyproj Current "2.6.1.post1-2" as the version. When I launch QGIS and open the python console and try "import pyproj" I get.

import pyproj

Traceback (most recent call last):

File "D:\Users\user\OSGeo4W\apps\Python39\lib\code.py", line 90, in runcode

exec(code, self.locals)

File "<input>", line 1, in <module> File "D:/Users/user/OSGeo4W/apps/qgis/./python\qgis\utils.py", line 799, in _import

mod = _builtin_import(name, globals, locals, fromlist, level)

File "D:\Users\user\OSGeo4W\apps\Python39\lib\site-packages\pyproj\init.py", line 50, in <module>

from pyproj import _datadir

File "D:/Users/user/OSGeo4W/apps/qgis/./python\qgis\utils.py", line 799, in _import

mod = _builtin_import(name, globals, locals, fromlist, level)

ImportError?: DLL load failed while importing _datadir: The specified module could not be found.

comment:3 Changed 10 months ago by andreaerdna

The python3-pyproj-2.6.1.post1-2 from the testing repository is about 300 KB, while python3-pyproj-2.6.1.post1-1 from the "regular" repository is about 16 MB.

Moreover _datadir.cp39-win_amd64.pyd in python3-pyproj-2.6.1.post1-2 from the testing repository is linked to and needs proj_7_1.dll

comment:4 in reply to:  3 ; Changed 10 months ago by jef

Replying to andreaerdna:

The python3-pyproj-2.6.1.post1-2 from the testing repository is about 300 KB, while python3-pyproj-2.6.1.post1-1 from the "regular" repository is about 16 MB.

Not surprising - it contains proj, while osgeo4w's depends on proj.

.oO(16MB? piece of cake - installing python3-proj in the sandbox takes ages because it indirectly also depends on proj-data) .oO(and on and on…) .oO(bad download.osgeo.org day?) .oO(download.osgeo.org is in oregon)

Moreover _datadir.cp39-win_amd64.pyd in python3-pyproj-2.6.1.post1-2 from the testing repository is linked to and needs proj_7_1.dll

.oO(so let 's check that out while we're waiting…)

Last edited 10 months ago by jef (previous) (diff)

comment:5 in reply to:  4 Changed 10 months ago by jef

Resolution: fixed
Status: newclosed

Fixed in python3-pyproj 3.0.1-1

Note: See TracTickets for help on using tickets.