Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#660 closed defect (fixed)

Installation of QGIS-ltr 3.16.4 (32bit) failed

Reported by: Andreas Müller Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords:
Cc:

Description

I just tried to (fresh) install the new ltr, but the installs reported errors. Rebooting and starting qgis says DLL not found: qgis_app.dll, but which exists. I attached the log file.

Attachments (4)

setup.log.full.zip (124.5 KB) - added by Andreas Müller 11 months ago.
setup.log.full
setup.log.full_x64.zip (74.7 KB) - added by peetwhittaker 11 months ago.
workspaces_2021-02-22_04-38-50.png (18.0 KB) - added by peetwhittaker 11 months ago.
workspaces_2021-02-22_05-05-51.png (10.5 KB) - added by peetwhittaker 11 months ago.

Download all attachments as: .zip

Change History (9)

Changed 11 months ago by Andreas Müller

Attachment: setup.log.full.zip added

setup.log.full

Changed 11 months ago by peetwhittaker

Attachment: setup.log.full_x64.zip added

Changed 11 months ago by peetwhittaker

Changed 11 months ago by peetwhittaker

comment:1 Changed 11 months ago by peetwhittaker

I also experienced this using the 64-bit OSGeo4W Setup utility (see attached for setup log file). During the postinstall script for qgis-ltr-common, I got an error message stating that crssync.exe couldn't start "because libprotobuf-lite.dll is missing" (see attached image). The installer then reported the following info "qgis-ltr-common.bat exit code -1073741515".

Launching QGIS then failed as it "could not load qgis_app.dll" (see attached image).

comment:2 Changed 11 months ago by jef

Resolution: fixed
Status: newclosed

comment:3 Changed 11 months ago by peetwhittaker

Is this fixed in the current release? I am still getting the above error when upgrading an existing 3.10.x installation to 3.16.4

comment:4 in reply to:  3 ; Changed 11 months ago by jef

Replying to peetwhittaker:

Is this fixed in the current release? I am still getting the above error when upgrading an existing 3.10.x installation to 3.16.4

If you are refering to the libprotobuf-lite.dll error - yes, the missing dependency to protobuf was added to qgis-ltr-common.

comment:5 in reply to:  4 Changed 11 months ago by peetwhittaker

Replying to jef:

If you are refering to the libprotobuf-lite.dll error - yes, the missing dependency to protobuf was added to qgis-ltr-common.

Yes, sorry - I updated an existing QGIS 3.10.9 installation and got the "could not load qgis_app.dll" error message when launching QGIS so just assumed it was the same issue. Looking at the packages, it appears that protobuf is indeed installed.

It turns out that the issue was caused by running the osgeo4w-setup-x86_64.exe installer without the --upgrade-also option (see command below). Adding this fixed the issue. However, I am somewhat surprised that updating a package doesn't also update its dependencies automatically? Apologies if this is getting off-topic, happy to discuss on another ticket/on the mailing list/elsewhere :)

Command used to update QGIS:

osgeo4w-setup-x86_64.exe --arch x86_64 --root "C:\OSGeo4W64" --no-desktop --autoaccept --quiet-mode --site http://download.osgeo.org/osgeo4w --packages qgis-ltr
Last edited 11 months ago by peetwhittaker (previous) (diff)
Note: See TracTickets for help on using tickets.