#657 closed defect (fixed)

GRASS 7 plugin not working: 3.10.13-2, 3.16.2-2 standalone installers and OSGeo4W network installer

Reported by: andreaerdna Owned by: osgeo4w-dev@…
Priority: critical Component: Package
Version: Keywords:
Cc:

Description

Using QGIS installed via 3.10.13-2, 3.16.2-2 standalone installers or via OSGeo4W network installer, is it not possible to use the GRASS7 plugin in QGIS. The following error is reported in the Log Messages panel:

WARNING    GRASS init error : Problem in GRASS
initialization, GRASS provider and plugin will not work : Module built
against version d8fbd49af but trying to use version 2b6ab2893. You need to
rebuild GRASS GIS or untangle multiple installations.

Moreover, a wrong "QGIS Desktop 3.16.2 with GRASS 7.8.4" shortcut is created in the Windows Starts menu, instead of a "QGIS Desktop 3.16.2 with GRASS 7.8.5".

So I think the qgis-grass-plugin7-3.16.2 and qgis-ltr-grass-plugin7-3.10.13 plugins should be rebuild against GRASS 7.8.5.

Change History (1)

comment:1 Changed 12 months ago by andreaerdna

Resolution: fixed
Status: newclosed

Fixed in 3.10.14 and 3.16.3.

Note: See TracTickets for help on using tickets.