Opened 2 years ago

Closed 2 years ago

#582 closed defect (fixed)

"o-help" broken

Reported by: TobWen Owned by: osgeo4w-dev@…
Priority: minor Component: Package
Version: Keywords: o-help
Cc:

Description

I've installed OSGeo4W on a fresh system, but after starting OSGeo4W.bat, I can't use o-help anymore.

run o-help for a list of available commands
C:\OSGeo4W64>o-help
                   -={ OSGeo4W Shell Commands }=-
find: '.exe': No such file or directory
find: '.bat': No such file or directory




GDAL 2.3.2, released 2018/09/21

It stopped working on four other machines after running updates (Windows 7 Pro, Windows 10 Pro). It worked in the past and I didn't change my workflow.

Attachments (1)

o-help.bat (1.2 KB) - added by TobWen 2 years ago.
Fix for #582

Download all attachments as: .zip

Change History (4)

comment:1 Changed 2 years ago by jef

Priority: criticalminor

Changed 2 years ago by TobWen

Attachment: o-help.bat added

Fix for #582

comment:2 Changed 2 years ago by TobWen

I've just fixed the problem. When installing "R-Tools" or other applications, who bring their own find (f.e. GNU find), the PATH variable get messed up. Using the fix supplied, Microsoft Windows' find.exe is used.

if exist *.%%a dir /d *.%%a | find ".%%a" >>"%temp%\o-help-list.txt"

vs.

if exist *.%%a dir /d *.%%a | %windir%\system32\find ".%%a" >>"%temp%\o-help-list.txt"
Last edited 2 years ago by TobWen (previous) (diff)

comment:3 Changed 2 years ago by jef

Resolution: fixed
Status: newclosed

Refactored in shell-1.0.2-4

Note: See TracTickets for help on using tickets.