Opened 13 years ago

Closed 13 years ago

#54 closed defect (fixed)

qgis lacks the qwt5 library

Reported by: timmie Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords:
Cc:

Description

Hello, many QGIS plugins require the QWT5 library. This is not provided by the installer; thus many plugins won't work.

Please include that library.

Thanks

Change History (3)

comment:1 by jef, 13 years ago

Resolution: fixed
Status: newclosed

it's there. install pyqwt5-qt4

comment:2 by maphew, 13 years ago

Resolution: fixed
Status: closedreopened

shouldn't pyqwt5-qt4 be listed as a qgis dependency so it is automatically installed?

comment:3 by jef, 13 years ago

Resolution: fixed
Status: reopenedclosed

no, as pyqwt5-qt4 is not related to qgis and qgis doesn't depend on it.

We don't package python plugins, but if we did those would be the one to have such a dependency.

I think it's virtually impossible to keep up, if we were to package every potential dependancy a current or future plugin might need.

Note: See TracTickets for help on using tickets.