Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#492 closed defect (fixed)

scipy.ndimage fails to import

Reported by: kbevers Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords:
Cc:

Description

When importing scipy.ndimage from either a python console or script an ImportError is raised:

In [1]: import scipy.ndimage
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-1-ca78d1949b6c> in <module>()
----> 1 import scipy.ndimage

C:\OSGEO4~1\apps\Python27\lib\site-packages\scipy\ndimage\__init__.py in <module>()
    170 from __future__ import division, print_function, absolute_import
    171
--> 172 from .filters import *
    173 from .fourier import *
    174 from .interpolation import *

C:\OSGEO4~1\apps\Python27\lib\site-packages\scipy\ndimage\filters.py in <module>()
     35 from . import _ni_support
     36 from . import _nd_image
---> 37 from scipy.misc import doccer
     38
     39 __all__ = ['correlate1d', 'convolve1d', 'gaussian_filter1d', 'gaussian_filter',

C:\OSGEO4~1\apps\Python27\lib\site-packages\scipy\misc\__init__.py in <module>()
     45 from .common import *
     46 from numpy import who, source, info as _info
---> 47 from scipy.special import comb, factorial, factorial2, factorialk
     48
     49 import sys

C:\OSGEO4~1\apps\Python27\lib\site-packages\scipy\special\__init__.py in <module>()
    544 from __future__ import division, print_function, absolute_import
    545
--> 546 from ._ufuncs import *
    547
    548 from .basic import *

ImportError: DLL load failed: The specified module could not be found.

This happens for scipy version 0.14.0

Change History (5)

comment:1 by kbevers, 6 years ago

Resolution: invalid
Status: newclosed

The problem was caused by using a more recent version of numpy (1.11.x) than the one distributed with OSGeo4W (1.8.x). scipy.ndimage imports correctly when the proper version of numpy is used.

comment:2 by kbevers, 6 years ago

Resolution: invalid
Status: closedreopened

I am getting this error again after OSGeo4W adopted version 1.11.0. The problem has been confirmed on multiple computers in my office.

Maybe upgrade scipy to a more recent version, as there seem to be a conflict betweet the two packages in the current versions.

comment:3 by jef, 6 years ago

See also #511

comment:4 by jef, 6 years ago

Resolution: fixed
Status: reopenedclosed

fixed with numpy-1.11.0-2 (x86_64) (1.11.0-2 was missing fortran dlls)

Version 0, edited 6 years ago by jef (next)

comment:5 by kbevers, 6 years ago

That did the trick, thank you. Very impressive response time!

Note: See TracTickets for help on using tickets.